Forum: Ruby Problems with SRPM of ruby-1.8.4

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
0c00d644de3b8bb2f655908c79af25a5?d=identicon&s=25 Matt Lawrence (Guest)
on 2006-01-16 06:58
(Received via mailing list)
I'm building ruby-1.8.4 on CentOS4 (clone of RHEL4) and I ran into a
couple of problems.  First, the build requires libX11-devel which isn't
available for CentOS4 and doesn't seem to be needed.  Second, the build
uses yacc, but it is not listed as a requirement.

Very minor problems, but I thought y'all shoul know.

-- Matt
Nothing great was ever accomplished without _passion_
Fcd0e4a77335a364f15014590c612352?d=identicon&s=25 Aredridel (Guest)
on 2006-01-16 08:37
(Received via mailing list)
On Mon, 2006-01-16 at 14:56 +0900, Matt Lawrence wrote:
> I'm building ruby-1.8.4 on CentOS4 (clone of RHEL4) and I ran into a
> couple of problems.  First, the build requires libX11-devel which isn't
> available for CentOS4 and doesn't seem to be needed.  Second, the build
> uses yacc, but it is not listed as a requirement.

Whose SRPMs are these? I don't think there's official ones...
92324d1a212698587be6a5f349c7a9b4?d=identicon&s=25 Oliver Andrich (oandrich)
on 2006-01-16 10:20
(Received via mailing list)
Hi,

your error message looks like you are using the packages from Fedora
Core 5, which includes libX11-devel. Recently, 1.8.4 has been added to
updates for Fedora Core 4. Take this SRPM and it shall work.

Best regards,
Oliver

2006/1/16, Matt Lawrence <matt@technoronin.com>:
19f65b7dca6831edf989224b5ebd3fe0?d=identicon&s=25 unknown (Guest)
on 2006-01-16 18:22
(Received via mailing list)
On Monday 16 January 2006 02:56 pm, Matt Lawrence wrote:
> I'm building ruby-1.8.4 on CentOS4 (clone of RHEL4) and I ran into a
> couple of problems.  First, the build requires libX11-devel which isn't
> available for CentOS4 and doesn't seem to be needed.  Second, the build
> uses yacc, but it is not listed as a requirement.
>
> Very minor problems, but I thought y'all shoul know.
>
> -- Matt
> Nothing great was ever accomplished without _passion_

ENOTFROMRUBYLANG

Tsume
This topic is locked and can not be replied to.