Forum: Ruby on Rails uninitialized constant Test

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
9d2ae4f6fbea3cdf89f4323b256140bc?d=identicon&s=25 Shad Reynolds (Guest)
on 2006-01-08 16:18
(Received via mailing list)
I recently upgraded to Rails 1.0 and started a new project.  I've
started writing some tests, but when I run rake, I just get the
following...


Amnesia:~/Development/Rails/pog shad$ rake
(in /Users/shad/Development/Rails/pog)
/usr/bin/ruby -Ilib:test
"/usr/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake/rake_test_loader.rb"
"test/unit/pog_test.rb"
/usr/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:200:in
`const_missing': uninitialized constant Test (NameError)
        from ./test/unit/../test_helper.rb:6
        from ./test/unit/pog_test.rb:1:in `require'
        from ./test/unit/pog_test.rb:1
        from
/usr/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake/rake_test_loader.rb:5:in
`load'
        from
/usr/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake/rake_test_loader.rb:5
        from
/usr/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake/rake_test_loader.rb:5:in
`each'
        from
/usr/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake/rake_test_loader.rb:5
/usr/bin/ruby -Ilib:test
"/usr/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake/rake_test_loader.rb"
"test/functional/pog_controller_test.rb"
/usr/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:200:in
`const_missing': uninitialized constant Test (NameError)
        from ./test/functional/../test_helper.rb:6
        from ./test/functional/pog_controller_test.rb:1:in `require'
        from ./test/functional/pog_controller_test.rb:1
        from
/usr/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake/rake_test_loader.rb:5:in
`load'
        from
/usr/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake/rake_test_loader.rb:5
        from
/usr/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake/rake_test_loader.rb:5:in
`each'
        from
/usr/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake/rake_test_loader.rb:5
rake aborted!
Test failures


Any ideas?  I'm pretty sure that "Test" should be defined, so I'm not
sure what I'm doing wrong (I don't think I've made any significant
changes since starting this project)

Thanks,
Shad
--
http://www.ShadReynolds.com
http://www.flickr.com/photos/shadreynolds/
This topic is locked and can not be replied to.