Forum: Ruby on Rails Rails 1.0 Crashing: Errno::EPIPE (Broken pipe):

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
1ed4bbef573bfc014d32356d53103ca2?d=identicon&s=25 phil swenson (Guest)
on 2006-01-05 16:19
Since we upgraded to Rails 1.0 and lighty last week we've had the rails
application crash daily with the following error in the production.log
file:


Errno::EPIPE (Broken pipe):
    /usr/local/lib/ruby/1.8/mysql.rb:1042:in `flush'
    /usr/local/lib/ruby/1.8/mysql.rb:1042:in `write'
    /usr/local/lib/ruby/1.8/mysql.rb:462:in `write'
    /usr/local/lib/ruby/1.8/mysql.rb:436:in `command'
    /usr/local/lib/ruby/1.8/mysql.rb:307:in `stat'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/conn
ection_adapters/mysql_adapter.rb:147:in `active?'

I put the full stack dump at the end of this post.

We are using MySQL 4.1.  Any thoughts on what might be causing this?

Thanks,

phil






Errno::EPIPE (Broken pipe):
    /usr/local/lib/ruby/1.8/mysql.rb:1042:in `flush'
    /usr/local/lib/ruby/1.8/mysql.rb:1042:in `write'
    /usr/local/lib/ruby/1.8/mysql.rb:462:in `write'
    /usr/local/lib/ruby/1.8/mysql.rb:436:in `command'
    /usr/local/lib/ruby/1.8/mysql.rb:307:in `stat'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/conn
ection_adapters/mysql_adapter.rb:147:in `active?'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/conn
ection_adapters/abstract/connection_specification.rb:103:in
`retrieve_connection
'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/conn
ection_adapters/abstract/connection_specification.rb:20:in `connection'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/base
.rb:1152:in `quote_bound_value'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/base
.rb:1133:in `replace_bind_variables'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/base
.rb:1133:in `replace_bind_variables'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/base
.rb:1122:in `sanitize_sql'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/base
.rb:942:in `add_conditions!'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/base
.rb:921:in `construct_finder_sql'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/base
.rb:395:in `find'
    /usr/local/lib/ruby/gems/1.8/gems/activerecord-1.13.2/lib/active_record/base
.rb:393:in `find'
    /app/models/user.rb:95:in `auth_user'
    /app/models/user.rb:79:in `authenticate'
    /app/controllers/application.rb:30:in `authorize'
    /usr/local/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/fi
lters.rb:354:in `call_filters'
    /usr/local/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/fi
lters.rb:350:in `call_filters'
    /usr/local/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/fi
    /usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/fcgi_handler.rb:53:in
`process!'
    /usr/local/lib/ruby/site_ruby/1.8/fcgi.rb:600:in `each_cgi'
    /usr/local/lib/ruby/site_ruby/1.8/fcgi.rb:597:in `each_cgi'
    /usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/fcgi_handler.rb:52:in
`process!'
    /usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/fcgi_handler.rb:22:in
`process!'
    /ci/rails/ext/public/dispatch.fcgi:24
1ed4bbef573bfc014d32356d53103ca2?d=identicon&s=25 phil swenson (Guest)
on 2006-01-05 16:22
phil swenson wrote:
> Since we upgraded to Rails 1.0 and lighty last week we've had the rails
> application crash daily

I shouldn't have said "crash".  The application is still running, it's
just that every query errors out as described.
2cd7ec719ca4f264bd0e3e4173b7401d?d=identicon&s=25 Dan Croak (croaky)
on 2006-04-03 20:54
phil swenson wrote:
> phil swenson wrote:
>> Since we upgraded to Rails 1.0 and lighty last week we've had the rails
>> application crash daily
>
> I shouldn't have said "crash".  The application is still running, it's
> just that every query errors out as described.

Phil,

Did you ever solve this problem?  I'm having the same issue with Rails
on lighttpd.

Thanks,
Dan
This topic is locked and can not be replied to.