Forum: Ruby Connecting to Oracle

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
344a8509ceecf109da23dea03a3c641c?d=identicon&s=25 Day, Chuck (Guest)
on 2006-01-04 20:12
(Received via mailing list)
I'm getting an error stating:

"The procedure entry point OCIServerRelease could not be located in the
dynamic link library OCI.dll."

The following are points:
- I installed ActiveRecord
- I then installed mswin-oci(i.e.
http://rubyforge.org/frs/?group_id=256&release_id=3136)
- My connection to Oracle works fine through SQLPlus, Toad and/or other
tools.
- If I remove the OCI files from the above URL, I get "database
configuration specifies nonexistent OCI8 adapter
(ActiveRecord::AdapterNotFound)" when running almost any command(i.e.
ruby script/server).

Thoughts?

Thanks for any help.
Chuck
25e11a00a89683f7e01e425a1a6e305c?d=identicon&s=25 Wilson Bilkovich (Guest)
on 2006-01-05 01:15
(Received via mailing list)
On 1/4/06, Day, Chuck <chuck.day@medtronic.com> wrote:
> tools.
> - If I remove the OCI files from the above URL, I get "database
> configuration specifies nonexistent OCI8 adapter
> (ActiveRecord::AdapterNotFound)" when running almost any command(i.e.
> ruby script/server).
>

What version of the Oracle client are you using?  Make sure you have
8i or newer, rather than 8.0.x.

Personally I've had the best luck on Windows with the 9i client.
Things are a bit more of a hassle with InstantClient or the 10g client
install.
This topic is locked and can not be replied to.