Forum: Rails deployment DB:Migrate - Rails requires RubyGems >= 1.3.2. Please install RubyGems and try again

5f58cf115f270c9e7d23ee178e372a62?d=identicon&s=25 Franck Fallateuf (ffallateuf)
on 2010-11-22 18:28
Hello,

I've been trying to deploy a Ruby on Rails application and everything
works fine until it tries to run the DB migration scripts, at which
point it fails:

*** [err :: test-app1] Rails requires RubyGems >= 1.3.2. Please install
RubyGems and try again: http://rubygems.rubyforge.org
*** [err :: test-app1]
 ** [out :: test-app1] (in
/filestore/rails/test/releases/20101117194037)
    command finished
failed: "sh -c 'cd /var/rails/test/releases/20101117194037 && rake
RAILS_ENV=production db:util:migrate'" on test-app1

If I attempt to run the rake command manually to run the DB scripts, I
see the same error:
[root@test-app1 current]# rake RAILS_ENV=production db:util:migrate
(in /filestore/rails/test/releases/20101118220117)
Rails requires RubyGems >= 1.3.2. Please install RubyGems and try again:
http://rubygems.rubyforge.org

Here's some more info:

[root@test-app1 current]# ruby -v
ruby 1.8.5 (2006-08-25) [x86_64-linux]

[root@test-app1 current]# gem -v
1.3.3

[root@test-app1 current]# rake --version
rake, version 0.8.7

[root@test-app1 current]# gem list

*** LOCAL GEMS ***

fastthread (1.0.7)
passenger (2.2.15)
rack (1.2.1)
rake (0.8.7)

[root@test-app1 current]# which ruby; which gem; which rake
/usr/bin/ruby
/usr/bin/gem
/usr/bin/rake

[root@test-app1 current]# whereis ruby; whereis gem; whereis rake
ruby: /usr/bin/ruby /usr/lib/ruby /usr/share/man/man1/ruby.1.gz
gem: /usr/bin/gem
rake: /usr/bin/rake

[root@test-app1 current]# gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.3
  - RUBY VERSION: 1.8.5 (2006-08-25) [x86_64-linux]
  - INSTALLATION DIRECTORY: /usr/lib64/ruby/gems/1.8
  - RUBY EXECUTABLE: /usr/bin/ruby
  - EXECUTABLE DIRECTORY: /usr/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - x86_64-linux
  - GEM PATHS:
     - /usr/lib64/ruby/gems/1.8
     - /root/.gem/ruby/1.8
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
     - :sources =>
["http://ec2-us-east-mirror.rightscale.com/rubygems/...]
  - REMOTE SOURCES:
     - http://ec2-us-east-mirror.rightscale.com/rubygems/...

I've done many different things to no avail.  I removed RubyGems and
reinstalled it (1.3.1, 1.3.2), I upgraded my version of Ruby to
Enterprise 1.8.7.

Could someone please help me out?

Thank you,
Franck
This topic is locked and can not be replied to.