Forum: Ruby on Rails MacOS X Tiger Rails Install problem

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Df44ac1bea41900d68fb4c63f6ff4bab?d=identicon&s=25 Doug Hall (Guest)
on 2006-01-03 20:11
(Received via mailing list)
According to the Hivelogic instructions <http://hivelogic.com/
articles/2005/12/01/ruby_rails_lighttpd_mysql_tiger> to correctly
installing RoR on Tiger:

>
> In this case, a possible fix might be to try running the following
> command, and answering yes when prompted to install each dependency:
>
> sudo gem install rails

Well, I tried installing Rails both with the --include-dependencies
option and without, and still got the "No such file to load" error.
One thing that I did differently was to install Ruby 1.8.4 instead of
1.8.2 - in hopes the problems with 1.8.3 had been resolved. Was this
where I went wrong? Anyone know the fix for this?

Thanks,
Doug
17acfbd3a05cfb59e0543235cc0a813b?d=identicon&s=25 joshua (Guest)
on 2006-01-03 20:28
Doug,

If you are trying to create a development environment, I'd suggest using
Locomotive. It is a Mac OS X app that provides a complete set of
packages for doing RoR dev. It has everything you need including
lighttpd. It's not a solution if you need edge Rails, but for gem Rails
it rocks.

http://locomotive.sourceforge.net/
B4a04ecbe2386b483c36695938f1c320?d=identicon&s=25 Jacob Patton (Guest)
on 2006-01-03 20:33
(Received via mailing list)
Hi Doug,

I'm not exactly sure why you're getting that error, but I recently
installed Rails, lighttpd, and MySQL on a fresh Tiger install using
Geoffrey Grosenbach's instructions here <
http://nubyonrails.com/articles/2005/12/29/an-even...
> (based on Dan Benjamin's), and he's upgraded the script to work with
ruby 1.8.4.  It worked great, but you might need to fix curl if it
won't stop downloading (see my comment at the bottom of the linked
page).

Best,

Jacob

-
Jacob Patton
Trisignia
http://trisignia.com/
Df44ac1bea41900d68fb4c63f6ff4bab?d=identicon&s=25 Doug Hall (Guest)
on 2006-01-03 21:06
(Received via mailing list)
I appreciate that advice. And I've tried Locomotive - and like it very
much.
The thing is, it solves some problems, but leaves me guessing on others.
Every tutorial and every book I've gotten my hands on so far are written
from the perspective of NOT having Locomotive. So, when I run into a
problem, I don't know whether it's because of my Locomotive setup, or
what.
Maybe I'm wrong, but I'm betting that if I have a conventional setup,
I'll
learn the solutions to problems that can only be learned the hard way.
(Just
like this one.) Kinda like how Java programmers swear that you should
start
with a text editor and then (maybe) eventually move to an IDE.

My $0.02
F690ec04b0501b74b033fc64ff4f682b?d=identicon&s=25 Dean Wampler (Guest)
on 2006-01-04 03:19
(Received via mailing list)
I'm going through some Tiger issues now... and using Locomotive to
avoid them ;)  One tip, if you need a terminal window, use the one you
get from Locomotive's "Rails > Open Terminal" menu item. It will
change the path to point to Locomotive's own instance of ruby, not the
default /usr/bin/ruby.

My $0.02,

dean

On 1/3/06, Doug Hall <doughalldev@gmail.com> wrote:
> My $0.02
> Rails@lists.rubyonrails.org
> http://lists.rubyonrails.org/mailman/listinfo/rails
>
>
>


--
Dean Wampler
http://www.aspectprogramming.com
http://www.newaspects.com
http://www.contract4j.org
95eb06f24b2e217e9f290f7227cdbf55?d=identicon&s=25 Dudley Flanders (Guest)
on 2006-01-06 19:30
(Received via mailing list)
On Jan 3, 2006, at 1:10 PM, Doug Hall wrote:
> Well, I tried installing Rails both with the --include-dependencies
> option and without, and still got the "No such file to load" error.
> One thing that I did differently was to install Ruby 1.8.4 instead
> of 1.8.2 - in hopes the problems with 1.8.3 had been resolved. Was
> this where I went wrong? Anyone know the fix for this?

That error means that whichever "ruby" command is first in your path
can't find the rubygems library. If you installed your ruby in /usr/
local, make sure that /usr/local/bin comes before /usr/bin in your
path. Otherwise you'll end up running Tiger's ruby. I'm not sure what
the --include-dependencies switch would have to do with finding the
rubygems library, though.

-dudley
2dd904ec5981c31e7bb7a5743a53caf8?d=identicon&s=25 Bruce Balmer (brucebalmer)
on 2006-01-06 21:28
(Received via mailing list)
try using locomotive instead.  google rails ruby locomotive. Much
easier, cleaner, simpler.  I was having install troubles myself which
is how I came upon locomotive. Highly recommended. 5 /5

bruce
95eb06f24b2e217e9f290f7227cdbf55?d=identicon&s=25 Dudley Flanders (Guest)
on 2006-01-07 02:07
(Received via mailing list)
On Jan 3, 2006, at 2:03 PM, Doug Hall wrote:

> an IDE.
Exactly right. 95% of everything I've learned has been incidental
knowledge gained on the road to solving some other problem.

-dudley
Df44ac1bea41900d68fb4c63f6ff4bab?d=identicon&s=25 Doug Hall (Guest)
on 2006-01-10 02:59
(Received via mailing list)
On 1/6/06, Dudley Flanders <dudley@misnomer.us> wrote:
>
>
> >  "No such file to load" error.
>
> That error means that whichever "ruby" command is first in your path
> can't find the rubygems library. If you installed your ruby in /usr/
> local, make sure that /usr/local/bin comes before /usr/bin in your
> path. Otherwise you'll end up running Tiger's ruby. I'm not sure what
> the --include-dependencies switch would have to do with finding the
> rubygems library, though.


Yep that was it. I put my install location first in my PATH, and all was
well. I had already discovered this before reading your message, but
thanks
just the same. Maybe someone else will read this and benefit from it. I
made
the mistake of having Darwin Ports and Fink and Apple's pre-installed
software, and... well my PATH was just too long and complicated. As a
rule
of thumb, always put Apple's paths LAST in the path, because anything
you
intentionally install, you probably want to run instead. (Common sense,
I
know, but it took me a while to recognize that rule of thumb.)

Doug
This topic is locked and can not be replied to.