Forum: Ruby on Rails Session and flash now working in IE6

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
1f8a2831a8b45f62eee765c96c67747a?d=identicon&s=25 Nickolay Kolev (Guest)
on 2006-01-02 12:18
(Received via mailing list)
Hi all,

I noticed that my sessions and flashes are not working in IE6 (no
problem with safari or firefox). I did a <%= debug session %> and
indeed IE6 is showing session[:new_session] to be true all the time.
This means a new session is created for every request.

An old version of the same application is running on the same server
under a different subdomain. In this sessions are working as expected
in the same browser (so browser cookie settings are probably not the
problem).

No changes have been made to the default rails session handling
configuration.

Why is the session not persisted? Where should I starts looking for
errors?

Many thanks in advance for any pointers!

Nicky
1f8a2831a8b45f62eee765c96c67747a?d=identicon&s=25 Nickolay Kolev (Guest)
on 2006-01-02 17:15
(Received via mailing list)
> Why is the session not persisted? Where should I starts looking for
> errors?

The error is in the subdomain which included an underscore.
Underscores in subdomains apparently cause such errors is IE. Now
there is an hour I am never getting back.

Nicky
This topic is locked and can not be replied to.