Forum: GNU Radio Control Port : Ctrlport Key called with unregistered key

98f854482c5b2165d5134535a0980cd7?d=identicon&s=25 Shashank Sinha (Guest)
on 2014-06-25 13:50
(Received via mailing list)
I was trying to use gr-perf-monitorx while running Bastian's
gr-ieee80211
project. I was encountering the following error :

{
    unknown =
/home/harsha_sdr/.Repos/gnuradio/gnuradio-runtime/include/gnuradio/rpcserver_ice.h:119:
IceUtil::IllegalArgumentException: Ctrlport Key called with unregistered
key (ofdm_preamble0::output % full)

I read about the possible reason for the error and updated
gnuradio-runtime.conf . It now stands as

[DEFAULT]
verbose = False

# The maximum number of messages a block will store up before pruning
# the queue by popping messages from the front.
max_messages = 100


[LOG]
# Levels can be (case insensitive):
#       DEBUG, INFO, WARN, TRACE, ERROR, ALERT, CRIT, FATAL, EMERG
log_level = debug
debug_level = emerg

# These file names can either be 'stdout' to output to standard output
# or 'stderr' to output to standard error. Any other string will
# create a file in which to output the logging information. An empty
# string or no value here will ignore this level of configuration
# completely.
log_file = stdout
debug_file = stderr

# Used for advanced configuration of the logger
#log_config = /usr/local/etc/gnuradio/gr_log_default.xml


[PerfCounters]
on = True
export = True
clock = thread
#clock = monotonic

[ControlPort]
on = True
edges_list = True
config = # /usr/local/etc/gnuradio/ctrlport.conf


I am stilling facing the error , even after making the changes as
suggested
on the Control Port usage page. Can someone explain what is going wrong
?
D9b2772a9387f5dbe010dbc0c3a93f8d?d=identicon&s=25 Douglas Geiger (Guest)
on 2014-06-25 15:51
(Received via mailing list)
How did you install GNURadio? The error suggests to me that performance
counters were not enabled at compile time. There is some information
about
enabling performance counters on the wiki page:
http://gnuradio.org/redmine/projects/gnuradio/wiki...

 Good luck,
  Doug


On Wed, Jun 25, 2014 at 7:48 AM, Shashank Sinha <shashsinboy@gmail.com>
C539637020fd56193dd6daec746c4a84?d=identicon&s=25 Tom Rondeau (Guest)
on 2014-06-25 15:53
(Received via mailing list)
On Wed, Jun 25, 2014 at 7:48 AM, Shashank Sinha <shashsinboy@gmail.com>
wrote:

> gnuradio-runtime.conf . It now stands as
> # Levels can be (case insensitive):
> debug_file = stderr
>
> [ControlPort]
> on = True
> edges_list = True
> config = # /usr/local/etc/gnuradio/ctrlport.conf
>
>
> I am stilling facing the error , even after making the changes as
> suggested on the Control Port usage page. Can someone explain what is going
> wrong ?
>


What version of GNU Radio are you running, and are you certain that
Performance Counters have been built into your system? Prior to version
3.7.3, Performance Counters were disabled by default at compile time.
You
would have to add the -DENABLE_PERFORMANCE_COUNTERS=True to cmake to
compile them in. Version 3.7.3 now enables these by default.

You can tell if your installation supports Performance Counters by
looking
at $prefix/gnuradio/config.h and seeing if there is a line:

#define GR_PERFORMANCE_COUNTERS

Tom
98f854482c5b2165d5134535a0980cd7?d=identicon&s=25 Shashank Sinha (Guest)
on 2014-06-25 15:54
(Received via mailing list)
I don't think so. ctrlport-monitor works fine.


On Wed, Jun 25, 2014 at 7:19 PM, Douglas Geiger <
C539637020fd56193dd6daec746c4a84?d=identicon&s=25 Tom Rondeau (Guest)
on 2014-06-25 15:57
(Received via mailing list)
On Wed, Jun 25, 2014 at 9:51 AM, Shashank Sinha <shashsinboy@gmail.com>
wrote:

> I don't think so. ctrlport-monitor works fine.
>

ctrlport-monitor doesn't use Performance Counters.

Tom
A778d8812929a4b21baa7fc3b898dd87?d=identicon&s=25 Bastian Bloessl (Guest)
on 2014-06-25 16:36
(Received via mailing list)
Hi Shashank,

On 06/25/2014 01:48 PM, Shashank Sinha wrote:
> I was trying to use gr-perf-monitorx while running Bastian's
> gr-ieee80211 project. I was encountering the following error :
>

I just reran the example and it works for me, but maybe you can run the
performance monitor for a simple flow graph with GNU Radio blocks only,
just to assure that the error is not related to the 802-11 stuff...


Best,
Bastian
98f854482c5b2165d5134535a0980cd7?d=identicon&s=25 Shashank Sinha (Guest)
on 2014-06-26 18:14
(Received via mailing list)
I re-installed UHD drivers, GNU Radio as well as gr-foo and gr-ieee80211
.
I started to run the transmitter with Performance Monitor but got the
following error:

ctrlport-monitor: radio.get threw exception (math domain error).

I tried looking for an explanation online but was unsuccessful. Any
ideas
to the reason for the error. I am pretty sure it is not related to
gr-ieee80211.

Specs:
GNU Radio - 3.7.3
UHD Driver - 3.7.1
RF Front-End - NI USRP- 2920
OS - Ubuntu 12.04


On Wed, Jun 25, 2014 at 8:04 PM, Bastian Bloessl <bloessl@ccs-labs.org>
C539637020fd56193dd6daec746c4a84?d=identicon&s=25 Tom Rondeau (Guest)
on 2014-06-26 20:57
(Received via mailing list)
On Thu, Jun 26, 2014 at 12:12 PM, Shashank Sinha <shashsinboy@gmail.com>
wrote:

> Specs:
> GNU Radio - 3.7.3
> UHD Driver - 3.7.1
> RF Front-End - NI USRP- 2920
> OS - Ubuntu 12.04
>


Are you running gr-ctrlport-monitor from the command line or using the
GRC
block?

If using this the latter way, I've noticed this happening on very
complex
flowgraphs. I think it basically makes a call to the flowgraph that the
flowgraph doesn't properly respond to or provides a 0 result. If you
launch
the flowgraph first and then call the gr-ctrlport-monitor from the
command
line in a terminal, instead, the problem should go away.

Also, you could try running a simpler flowgraph just to verify that this
and the performance monitor tool are working in a more controlled
experiment.

Also, can you get the line number for where the assertion is coming
from?
It'd be good if we could put a check in there to prevent it from
crashing
like this.

Thanks,
Tom
This topic is locked and can not be replied to.