Forum: Ruby Building Ruby-1.8.4 on WinXP with MSVC++ 8.0

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
1d8d318b49aebd4265b6da27efe6f8c6?d=identicon&s=25 Glenn M. Lewis (Guest)
on 2005-12-29 05:50
(Received via mailing list)
Hi!  I'm building Ruby-1.8.4 on WinXP SP2 using MSVC++ 8.0,
and first did the 'win32\configure.bat' and then typed nmake.
It makes a fair amount of progress until it gets to 'miniruby'
and then dies like so:

          cl -nologo main.obj dmydln.obj msvcr80-ruby18-static.lib
oldnames.lib user32.lib advapi32.lib wsock32.lib  -Feminiruby.exe -link
-incremental:no -debug -opt:ref -opt:icf
rbconfig.rb updated
         .\miniruby.exe ./win32/mkexports.rb -output=msvcr80-ruby18.def
msvcr80-ruby18-static.lib
../win32/mkexports.rb:6: [BUG] Segmentation fault
ruby 1.8.4 (2005-12-24) [i386-mswin32]


This application has requested the Runtime to terminate it in an unusual
way.
Please contact the application's support team for more information.
NMAKE : fatal error U1077: '.\miniruby.exe' : return code '0x3'
Stop.

Any ideas what I might be doing wrong?
Thanks!
-- Glenn
04a56914cc09f0858d3fca2bf4cbde34?d=identicon&s=25 nobuyoshi nakada (Guest)
on 2005-12-29 06:39
(Received via mailing list)
Hi,

At Thu, 29 Dec 2005 13:47:54 +0900,
Glenn M. Lewis wrote in [ruby-talk:172930]:
> Hi!  I'm building Ruby-1.8.4 on WinXP SP2 using MSVC++ 8.0,
> and first did the 'win32\configure.bat' and then typed nmake.
> It makes a fair amount of progress until it gets to 'miniruby'
> and then dies like so:

VC8 support is in progress now.

See the thread from [ruby-core:06996] for more details.
http://www.ruby-talk.org/cgi-bin/vframe.rb/ruby/ru...
31ab75f7ddda241830659630746cdd3a?d=identicon&s=25 Austin Ziegler (Guest)
on 2005-12-29 13:59
(Received via mailing list)
On 29/12/05, nobuyoshi nakada <nobuyoshi.nakada@ge.com> wrote:
> See the thread from [ruby-core:06996] for more details.
> http://www.ruby-talk.org/cgi-bin/vframe.rb/ruby/ru...

Yes. I've been a bit busy over the last couple of days and although I
took the computer that I am doing this on to work yesterday, I forgot
its network card ;) so I couldn't really do anything with it. I will
be continuing to attempt this.

Worse, it appears that there's a problem with trying to build OpenSSL
0.9.7 or 0.9.8 with cl version 14 as well; mostly along the same
lines, but the latest patches for *that* cause different issues.

-austin
This topic is locked and can not be replied to.