Forum: Ruby on Rails routes.rb

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
4673d16b9d06e2f162e363b5baedabac?d=identicon&s=25 Ramesh R (Guest)
on 2005-12-29 05:47
(Received via mailing list)
Hi I am very new to Ruby and Rails.
I am trying to setup a simple application on Apache with MySQL on a
Fedora system.
I have trouble setting up fast cgi, I am trying to deal with it.
But is fast cgi mandatory?  From what I have read it boosts the
performance of the rails application.

I tried a scaffold application and I am able to run it using webbrick.
 I am trying to set this up in Apache but I am stuck with changing the
default route.
I have enabled CGI in apache and when I point my browser to the public
folder I am able to see the "Congratulations, you've put Ruby on
Rails!" page.  But I am not able to configure it run the application.
The name of the application is blogtest and I have set the Alias
(/blogtest) and Directory options in Apache's httpd.conf file to the
public folder of the rails application.
The application has a controller named admin (admin_controller.rb)

I tried my best to search on the net and find out something I could
understand but wasn't able to figure out. If someone could explain me
how to configure and help me understand how it all works that will be
great.

Thanks
Ramesh
6828ffc79486cd2442714bf32286a910?d=identicon&s=25 Vivek Krishna (Guest)
on 2005-12-30 05:21
(Received via mailing list)
>
> But is fast cgi mandatory?  From what I have read it boosts the
> performance of the rails application.

No ,its not mandatory ..atleast not for development phase

I tried a scaffold application and I am able to run it using webbrick.
> I am trying to set this up in Apache but I am stuck with changing the
> default route.


Have you setup  a Virtual host or a Directory alias in Apache ?
I guess if you are seeing the Rails welcome page that must be taken care
of.
So open the routes.rb  and add (as given in the comments ) something
like
this
map.connect ' ', :controller => "admin" ,:action =>'index'
42292bf8a0acbc98862d9306b501275d?d=identicon&s=25 Daniel Waite (rabbitcreative)
on 2005-12-30 05:51
(Received via mailing list)
Delete the index.html file if you haven't already.

The .htaccess file looks for that first. If it's found, your application
won't start.

- Rabbit

---
This topic is locked and can not be replied to.