Forum: Ruby rubygems win32 error with ruby 1.8.4 (final)

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
0bee7f89111c8d7551e7c5a39e3c24d7?d=identicon&s=25 simonh (Guest)
on 2005-12-27 11:13
(Received via mailing list)
hi all. i'm using the ruby 1.8.4 binary from garbagecollect with dll's
mentioned in the 'how to install' section. all seems fine except
rubygems reports this error when i try to install anything -

"Could not find RubyGem sources (0.0.0) (Gem::LoadError).

according to the gems website this was a problem with an earlier
version, but i'm using 0.8.11

thanks for any ideas
0bee7f89111c8d7551e7c5a39e3c24d7?d=identicon&s=25 simonh (Guest)
on 2005-12-28 11:30
(Received via mailing list)
or does someone have a link to the preview3 of ruby 1.8.4? i'm pretty
sure that worked ok.
Ce60c4f78a63b0695e4dafc4bd7964f7?d=identicon&s=25 Lou Vanek (Guest)
on 2005-12-28 12:42
(Received via mailing list)
you may just need to set a few environmental variables to
indicate to ruby and gem where to look for your files.
the following is an example for somebody using a bash shell.
your paths and shell may differ -- adjust accordingly.

export RUBYLIB=/lib/ruby/site_ruby/1.8:/lib/ruby/1.8
export GEM_PATH=/lib/ruby/gems/1.8
export GEM_HOME=/lib/ruby/gems/1.8
0bee7f89111c8d7551e7c5a39e3c24d7?d=identicon&s=25 simonh (Guest)
on 2005-12-28 19:10
(Received via mailing list)
well, it was a blasted dll issue. i love windows! long live microsuck
560c83ff6b6600e39315a1cf75b7c229?d=identicon&s=25 Tom Copeland (Guest)
on 2005-12-29 04:56
(Received via mailing list)
On Wed, 2005-12-28 at 19:27 +0900, simonh wrote:
> or does someone have a link to the preview3 of ruby 1.8.4? i'm pretty
> sure that worked ok.

FWIW, lots of past Ruby versions are mirrored here:

http://rubyforge.org/frs/?group_id=426

Yours,

Tom
This topic is locked and can not be replied to.