Forum: Ruby WinXP, no braces in irb.

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
07b54eeca41339c4c5474efc079a4c79?d=identicon&s=25 klausa (Guest)
on 2005-12-22 23:30
(Received via mailing list)
Hi,

I just started learning ruby. Installed on WinXP. Opened a command
window. Whenever I type a brace it appears on the creen. After typing
irb no more braces.. Why? What can I do?? TIA for any help.
07b54eeca41339c4c5474efc079a4c79?d=identicon&s=25 klausa (Guest)
on 2005-12-22 23:39
(Received via mailing list)
On Thu, 22 Dec 2005 23:26:27 +0100, klausa <iIdont@wantnospamm.net>
wrote:

>Hi,
>
>I just started learning ruby. Installed on WinXP. Opened a command
>window. Whenever I type a brace it appears on the creen. After typing
>irb no more braces.. Why? What can I do?? TIA for any help.


The same goes for square brackets and the baclslash. I am using a
german keyboard. But the german umlauts (characters with two dots on
top) appear in irb when I type them on the keyboard. Any ideas?
Cff9eed5d8099e4c2d34eae663aae87e?d=identicon&s=25 Jacob Fugal (Guest)
on 2005-12-23 00:00
(Received via mailing list)
On 12/22/05, klausa <iIdont@wantnospamm.net> wrote:
> The same goes for square brackets and the baclslash. I am using a
> german keyboard. But the german umlauts (characters with two dots on
> top) appear in irb when I type them on the keyboard. Any ideas?

This has come up several times in the past. I don't remember what the
resolution status is, but try searching for "keyboard irb" on google
groups for comp.lang.ruby. Here's a link:

  http://groups.google.com/group/comp.lang.ruby/sear...

Jacob Fugal
92324d1a212698587be6a5f349c7a9b4?d=identicon&s=25 Oliver Andrich (Guest)
on 2005-12-23 08:38
(Received via mailing list)
klausa schrieb:
> On Thu, 22 Dec 2005 23:26:27 +0100, klausa <iIdont@wantnospamm.net>
>>I just started learning ruby. Installed on WinXP. Opened a command
>>window. Whenever I type a brace it appears on the creen. After typing
>>irb no more braces.. Why? What can I do?? TIA for any help.
>
> The same goes for square brackets and the baclslash. I am using a
> german keyboard. But the german umlauts (characters with two dots on
> top) appear in irb when I type them on the keyboard. Any ideas?

Well, you have to configure some some things for it. Sadly. Here are the
steps that worked for me.

1. Create a file ".inputrc"

First you have to create an .inputrc in your home dir to configure the
mappings for the braces, and so on. Your homedir is here:

C:\Dokumente und Einstellungen\<Username on Windpows>

And the content should be:

"\M-[": "["
"\M-]": "]"
"\M-{": "{"
"\M-}": "}"
"\M-\\": "\\"
"\M-|": "|"
"\M-@": "@"
"\M-~": "~"

2. Activate readline in irb

In the same directory create a .ircrb file with the following content.

require 'irb/completion'
ARGV.concat [ "--readline", "--prompt-mode", "simple" ]

3. Setting set HOME environment variable.

The last step is to set a "Umgebungsvariable" :) /Environment variable
HOME the before mentioned diretory/path.

Afterwards it works fine for me.

Best regards,
Oliver
This topic is locked and can not be replied to.