Forum: Ruby on Rails Switchtower Hangs

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
A944b656e1e9cfd45f1e6714435b0a54?d=identicon&s=25 Simon Harris (Guest)
on 2005-12-21 12:21
(Received via mailing list)
I'm trying to get switchtower running on Mac OS X but it hangs logging
into the
server.

I've removed all traces of the original ruby installation and have
installed and
re-installed ruby 1.8.3 from sources a dozen times but nothing seems to
work.

I get the following error when running the net-ssh tests:

    ERROR:  304 tests, 655 assertions, 4 failures, 44 errors

I installed ruby into /usr/local/... with the following options:

sudo ./configure --enable-shared --enable-pthread --enable-install-doc

Cheers,

Simon
71ba43f1c8a91654a6c5749b8ea76eb6?d=identicon&s=25 James duncan Davidson (duncan)
on 2005-12-21 19:52
Simon Harris wrote:
> I'm trying to get switchtower running on Mac OS X but it hangs logging
> into the
> server.

I've had no issues with Switchtower on Mac OS X both with Ruby 1.8.2 and
1.8.3 (keep in mind that there are strange issues with Rails and 1.8.3).
The difference in my builds from yours is that I didn't build with
pthreads. Don't know if that's the crux of the issue or not, but worth
mentioning.
This topic is locked and can not be replied to.