Forum: Ruby mkdir command failed in fileutils.rb

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
F151259b60597a181f2cae3c56f13be3?d=identicon&s=25 Phil Lou (ter)
on 2014-06-09 23:32
Hi, Ruby-group:

Please help me with the following question. When I run the script, I got
the following errors, regarding "mkdir" cannot be executed in
fileutils.rb.

Since this error is located in the lib file,
should any modifications be made in this common lib file? My sense says
no.
If the patch should be make, wonder what the workaround/true fix is and
where to apply it?

Errorlog
==============================================


Withdrawn as problem was already solved.
54404bcac0f45bf1c8e8b827cd9bb709?d=identicon&s=25 7stud -- (7stud)
on 2014-06-10 02:01
FileUtils.mkdir_p /net/gridmaster.chaos.local

Or:

FileUtils.mkdir '/net'
FileUtils.mkdir '/net/gridmaster.chaos.local'

But I already have a /net directory, and if I run:

FileUtils.mkdir '/net/gridmaster.chaos.local'

...my ruby program hangs.
This topic is locked and can not be replied to.