Forum: Ruby on Rails HTTPI::SSLError - Plz help

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
49d975ae3818cebbb9c4de3adc7c86a9?d=identicon&s=25 Usha Murali (Guest)
on 2014-05-27 07:52
(Received via mailing list)
Dear All,

rvm ssl updated sucessfully and Openssl/ca cert seems to be correct in
my
system but still i get  HTTPI::SSL Error, Plz help me , my environment
as
follows:

$ whereis openssl
openssl: /usr/bin/openssl /usr/include/openssl
/usr/share/man/man1/openssl.
1ssl.gz

$ env | grep -i "ssl"
SSL_CERT_FILE=/usr/lib/ssl/cert.pem

$ rvm osx-ssl-certs status all
Certificates for /usr/lib/ssl/cert.pem: Up to date.

rvm osx-ssl-certs status all
Certificates for /usr/lib/ssl/cert.pem: Up to date.

$ rvm reload
RVM reloaded


Still it throws the following error, plz suggest how to resolve this, I
have spent nearly one day still cant figure out the issue, plz help me ,
the error as follws:

HTTPI::SSLError in searchesController

SSL_connect returned=1 errno=0 state=SSLv3 read server hello A: sslv3
alert handshake failure
SSL_connect returned=1 errno=0 state=SSLv3 read server hello A: sslv3
alert handshake failureRAILS_ROOT: /usha/myapp

2.1.0/lib/httpi/adapter/httpclient.rb:28:in `request'
/ruby-1.8.7-p330/gems/httpi-2.1.0/lib/httpi.rb:140:in `request'
.rvm/gems/ruby-1.8.7-p330/gems/httpi-2.1.0/lib/httpi.rb:112:in `post'
/.rvm/gems/ruby-1.8.7-p330/gems/savon-2.3.2/lib/savon/operation.rb:86:in
`call_with_logging'
.rvm/gems/ruby-1.8.7-p330/gems/savon-2.3.2/lib/savon/request_logger.rb:12:in
`call'
rvm/gems/ruby-1.8.7-p330/gems/savon-2.3.2/lib/savon/request_logger.rb:12:in
`/.rvm/gems/ruby-1.8.7-p330/gems/savon-2.3.2/lib/savon/client.rb:36:in
`call'

Any help is appreciated, Plz shed some light in this issue.
6883e5ef03484d4fcef507d7b4f1d243?d=identicon&s=25 Matt Jones (Guest)
on 2014-05-27 21:07
(Received via mailing list)
On Tuesday, 27 May 2014 00:51:47 UTC-5, Usha wrote:
>
> RVM reloaded
>
>
> Any help is appreciated, Plz shed some light in this issue.
>

Mislav's ssl doctor script (bottom of the post) can be useful:

http://mislav.uniqpath.com/2013/07/ruby-openssl/

If nothing else, posting what it outputs should provide more information
to
troubleshoot this issue.

--Matt Jones
49d975ae3818cebbb9c4de3adc7c86a9?d=identicon&s=25 Usha Murali (Guest)
on 2014-05-28 15:32
(Received via mailing list)
Hi plz see below for the ssl doctor script output:

export SSL_CERT_FILE=/usr/lib/ssl/cert.pem &  export
SSL_CERT_DIR=/usr/lib/ssl

*ruby doctor.rb localhost*
*/usr/local/bin/ruby (1.8.7-p330)*
*OpenSSL 0.9.8k 25 Mar 2009: /usr/lib/ssl*
*SSL_CERT_DIR="/usr/lib/ssl"*
*SSL_CERT_FILE="/usr/lib/ssl/cert.pem"*

*HEAD https://localhost:443 <https://localhost:443>*
*Error: connection refused*
6883e5ef03484d4fcef507d7b4f1d243?d=identicon&s=25 Matt Jones (Guest)
on 2014-05-28 17:22
(Received via mailing list)
On Wednesday, 28 May 2014 08:31:41 UTC-5, Usha wrote:
> *SSL_CERT_FILE="/usr/lib/ssl/cert.pem"*
>
> *HEAD https://localhost:443 <https://localhost:443>*
> *Error: connection refused*
>
>
Unless you've set up an SSL server on your local machine, this isn't
going
to work. Try pointing the script at the actual server that you're
getting
the SSLErrors from.

--Matt Jones
49d975ae3818cebbb9c4de3adc7c86a9?d=identicon&s=25 Usha Murali (Guest)
on 2014-05-30 09:36
(Received via mailing list)
Hi,
In my system, netstat -nlt | egrep ':443' does output anything.....

 So far i downloaded cert certificate, should'nt i do it instead create
self signed cert  in my local itself?? Also plz educate whatz the
difference that  these two , 1. set my host as SSL server  2.and  simply
self sign certificate installation, among this which will I require to
fix this
 HTTPI::SSL error which occurs in my local implementation of SOAP
webservice (SSL enabled)? Plz give ur views to fix this.
This topic is locked and can not be replied to.