Forum: NGINX Compile nginx 1.4.7 --with-http_rewrite_module Error

680e0312b037cbb53d0a5f0d1d4c71f9?d=identicon&s=25 gaoping@richinfo.cn (Guest)
on 2014-05-13 05:25
(Received via mailing list)
hi:
     I compiled nginx1.4.7,add to --with-pcre=/root/nginx/pcre-8.34
--with-http_rewrite_module parameter;An error occurred :./configure:
error: invalid option "--with-http_rewrite_module" ,Trouble who can talk
about what is the problem



gaoping@richinfo.cn
671d9faabfe3d3382be736b93fbfa1d5?d=identicon&s=25 Steve Holdoway (Guest)
on 2014-05-13 07:09
(Received via mailing list)
On Tue, 2014-05-13 at 11:25 +0800, gaoping@richinfo.cn wrote:
> hi:
>      I compiled nginx1.4.7,add
> to --with-pcre=/root/nginx/pcre-8.34 --with-http_rewrite_module parameter;An
error occurred :./configure: error: invalid option "--with-http_rewrite_module"
,Trouble who can talk about what is the problem
>

It's on by default. You can switch it off with the
--without-http_rewrite_module flag.

hth,

Steve


--
Steve Holdoway BSc(Hons) MIITP
http://www.greengecko.co.nz
Linkedin: http://www.linkedin.com/in/steveholdoway
Skype: sholdowa
680e0312b037cbb53d0a5f0d1d4c71f9?d=identicon&s=25 gaoping@richinfo.cn (Guest)
on 2014-05-14 00:38
(Received via mailing list)
Think you
    But If I turn off the words,I have no way is to use  'if' order.An
error occurred : [emerg] 14499#0: unknown directive "if($remote_addr" in
/usr/local/nginx1/conf/nginx.conf:46



gaoping@richinfo.cn

From: Steve Holdoway
Date: 2014-05-13 13:09
To: nginx
Subject: Re: Compile nginx 1.4.7 --with-http_rewrite_module Error
On Tue, 2014-05-13 at 11:25 +0800, gaoping@richinfo.cn wrote:
> hi:
>      I compiled nginx1.4.7,add
> to --with-pcre=/root/nginx/pcre-8.34 --with-http_rewrite_module parameter;An
error occurred :./configure: error: invalid option "--with-http_rewrite_module"
,Trouble who can talk about what is the problem
>

It's on by default. You can switch it off with the
--without-http_rewrite_module flag.

hth,

Steve


--
Steve Holdoway BSc(Hons) MIITP
http://www.greengecko.co.nz
Linkedin: http://www.linkedin.com/in/steveholdoway
Skype: sholdowa
40b4c848b8fcd63b0cb60b9d170c3a77?d=identicon&s=25 Valentin V. Bartenev (Guest)
on 2014-05-14 02:19
(Received via mailing list)
On Tuesday 13 May 2014 13:34:11 gaoping@richinfo.cn wrote:
> Think you
>     But If I turn off the words,I have no way is to use  'if' order.An error
> occurred : [emerg] 14499#0: unknown directive "if($remote_addr" in
> /usr/local/nginx1/conf/nginx.conf:46

There is no directive "if($remote_addr" in nginx.

Evidently you have missed a space after the "if" directive.

  wbr, Valentin V. Bartenev
680e0312b037cbb53d0a5f0d1d4c71f9?d=identicon&s=25 gaoping@richinfo.cn (Guest)
on 2014-05-14 02:25
(Received via mailing list)
ngx_http_rewrite_module
syntax:if (condition) { ... }
default:—
context:server, location
I use in location',



gaoping@richinfo.cn

From: Valentin V. Bartenev
Date: 2014-05-13 15:15
To: nginx
Subject: Re: Compile nginx 1.4.7 --with-http_rewrite_module Error
On Tuesday 13 May 2014 13:34:11 gaoping@richinfo.cn wrote:
> Think you
>     But If I turn off the words,I have no way is to use  'if' order.An error
> occurred : [emerg] 14499#0: unknown directive "if($remote_addr" in
> /usr/local/nginx1/conf/nginx.conf:46
There is no directive "if($remote_addr" in nginx.

Evidently you have missed a space after the "if" directive.

  wbr, Valentin V. Bartenev
680e0312b037cbb53d0a5f0d1d4c71f9?d=identicon&s=25 gaoping@richinfo.cn (Guest)
on 2014-05-14 03:39
(Received via mailing list)
Think you
     The problem has been resolved.Because 'if($remote_addr' ,  'If' and
'('  a space is required between


gaoping@richinfo.cn

From: Valentin V. Bartenev
Date: 2014-05-13 15:15
To: nginx
Subject: Re: Compile nginx 1.4.7 --with-http_rewrite_module Error
On Tuesday 13 May 2014 13:34:11 gaoping@richinfo.cn wrote:
> Think you
>     But If I turn off the words,I have no way is to use  'if' order.An error
> occurred : [emerg] 14499#0: unknown directive "if($remote_addr" in
> /usr/local/nginx1/conf/nginx.conf:46
There is no directive "if($remote_addr" in nginx.

Evidently you have missed a space after the "if" directive.

  wbr, Valentin V. Bartenev
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.