Forum: JRuby NameError: uninitialized constant Krypt::Provider::JDK with JRuby 1.7.12

7c66f420afb18b862b28081dc8d4e86f?d=identicon&s=25 Ken E. (ken_e)
on 2014-04-29 21:44
After upgrading JRuby to 1.7.12 I get

NameError: uninitialized constant Krypt::Provider::JDK

when starting my application in WAS.

I noticed the release notes said bouncy-castle-java and krypt libraries
were unbundled from 1.7.12. Not sure what this means. My application
runs OK using WEBrick so clearly this is a packaging issue with WAS.

I tried adding krypt-core gem to my bundle file and that caused Warbler
to error with the same error.

I copied the krypt-core.jdk and kryptproviderjdk.jdk files to my lib
directory but no luck, same error with Warbler.

Any other ideas?
B05d3cbc64b0031a24c2887fb6ddc173?d=identicon&s=25 christian (Guest)
on 2014-04-29 22:25
(Received via mailing list)
did you use the krypt-0.0.2.rc1 gem and/or their jars ?
7c66f420afb18b862b28081dc8d4e86f?d=identicon&s=25 Ken E. (ken_e)
on 2014-04-30 15:07
christian wrote in post #1144446:
> did you use the krypt-0.0.2.rc1 gem and/or their jars ?

I'm not sure how I should know I NEED this version.

Adding krypt-core to my Gem file seemed to be the right thing to do
however it pulled down version 0.0.1. Adding 0.0.2.rc1 as a version
didn't even work. I had to uninstall everything and manually install the
0.0.2.rc1 versions of krypt-core and krypt-provider-jdk using gem
install. Once I did that, Warbler worked and the WAR file started
successfully in WAS.

Thanks for your help.
B05d3cbc64b0031a24c2887fb6ddc173?d=identicon&s=25 christian (Guest)
on 2014-04-30 16:12
(Received via mailing list)
to see the default gems of jruby itself I use this:

GEM_PATH=bla jruby -S gem list -l

since these gems are "already" installed bundler does not install them.
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.