Forum: Italian Ruby user group resque on heroku

Fe88efa62f2b20bdeb8689626d375f1e?d=identicon&s=25 Andrea Campolonghi (andreacfm)
on 2014-04-14 09:15
(Received via mailing list)
Ciao,

per la prima volta sto usando Resque su Heroku.
Premetto che la mia conoscenza di Heroku  scarsa ...
Nessun problema con il setup di Resque (che uso su molti altri progetti
con soddisfazione ) ma ho un problema che sembra venire dalla
problematica gestione dello shutdown dei workers.
Dopo ogni deploy o restart mi accorgo che non tutti i vecchi worker sono
stati killati a dovere e appaiono ancora "registrati" in Redis e quindi
appaiono
in resque-web.

Ho seguito la doc di Heroku in materia di Procfile:

worker: env TERM_CHILD=1 RESQUE_TERM_TIMEOUT=7 bundle exec rake
resque:workers COUNT=3

Qualcuno ha mai avuto lo stesso problema?

Grazie

Andrea

--
Andrea Campolonghi
32d80da41830a6e6c1bb3eb977537e3e?d=identicon&s=25 Alessandro R. (alessandro_r)
on 2014-04-28 19:27
(Received via mailing list)
I relativi processi li vedi ancora?
ps aux

Alessandro Rodi


2014-04-14 9:14 GMT+02:00 Andrea Campolonghi <acampolonghi@gmail.com>:
Fe88efa62f2b20bdeb8689626d375f1e?d=identicon&s=25 Andrea Campolonghi (andreacfm)
on 2014-04-30 07:49
(Received via mailing list)
No. Sono solo i worker che non escono correttamente e quindi non si
autoregistrano su redis. Ho provato anche resque pool senza successo.
Per
la prima volta sto provando sidekiq.

Il luned 28 aprile 2014, Alessandro Rodi <coorasse@gmail.com> ha
scritto:

> >
> > Ho seguito la doc di Heroku in materia di Procfile:
> > --
> http://lists.ruby-it.org/mailman/listinfo/ml
>


--
Andrea Campolonghi

Cell : +39 347 2298435
acampolonghi@gmail.com
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.