Forum: GNU Radio undefined reference to 'pthread_sigmask' error when make

Cbe40b7bbc4cb5bacfa90a1f49288e99?d=identicon&s=25 Jiao Xianjun (Guest)
on 2014-04-09 06:37
(Received via mailing list)
Hi,

I am trying to build gnuradio from source in Ubuntu 12.04.

http://jenkins.gnuradio.org/builds/gnuradio-current.tar.gz
and
3.7.3 release: http://gnuradio.org/releases/gnuradio/

are tried, but both encounter:

[ 33%] Generating xor_bb_impl.h, xor_ss_impl.h, xor_ii_impl.h
[ 33%] Generating xor_bb_impl.cc, xor_ss_impl.cc, xor_ii_impl.cc
Linking CXX executable gnuradio-config-info
[ 33%] [ 33%] Generating packed_to_unpacked_bb_impl.h,
packed_to_unpacked_ss_impl.h, packed_to_unpacked_ii_impl.h
Building CXX object
gnuradio-runtime/lib/CMakeFiles/test-gnuradio-runtime.dir/math/qa_math.cc.o
../lib/libgnuradio-runtime-3.7.4git.so.0.0.0: error: undefined reference
to
'pthread_setaffinity_np'
../lib/libgnuradio-runtime-3.7.4git.so.0.0.0: error: undefined reference
to
'pthread_sigmask'
collect2: ld returned 1 exit status
make[2]: *** [gnuradio-runtime/apps/gnuradio-config-info] Error 1
make[1]: ***
[gnuradio-runtime/apps/CMakeFiles/gnuradio-config-info.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 33%] [ 33%] Generating packed_to_unpacked_bb_impl.cc,
packed_to_unpacked_ss_impl.cc, packed_to_unpacked_ii_impl.cc
Building CXX object
gnuradio-runtime/lib/CMakeFiles/test-gnuradio-runtime.dir/math/qa_sincos.cc.o
[ 33%] Generating unpacked_to_packed_bb_impl.h,
unpacked_to_packed_ss_impl.h, unpacked_to_packed_ii_impl.h

even if I use -lpthread explicitly.

Anyone also encounter that? Thanks a lot!

cmake information is also attached:

-- The CXX compiler identification is GNU 4.6.3
-- The C compiler identification is GNU 4.6.3
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Build type not specified: defaulting to release.
-- Found Git: /usr/bin/git
-- Performing Test HAVE_VISIBILITY_HIDDEN
-- Performing Test HAVE_VISIBILITY_HIDDEN - Success
-- Performing Test HAVE_WARN_SIGN_COMPARE
-- Performing Test HAVE_WARN_SIGN_COMPARE - Success
-- Performing Test HAVE_WARN_ALL
-- Performing Test HAVE_WARN_ALL - Success
-- Performing Test HAVE_WARN_NO_UNINITIALIZED
-- Performing Test HAVE_WARN_NO_UNINITIALIZED - Success
-- Compiler Version: cc (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3
Copyright (C) 2011 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is
NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR
PURPOSE.
-- Compiler Flags: /usr/bin/cc:::-O3 -DNDEBUG
/usr/bin/c++:::-O3 -DNDEBUG
-- ADDING PERF COUNTERS
-- Found PythonLibs: /usr/lib/libpython2.7.so (found suitable version
"2.7.3", minimum required is "2")
-- Found SWIG: /usr/bin/swig2.0 (found version "2.0.4")
-- Minimum SWIG version required is 1.3.31
--
-- The build system will automatically enable all components.
-- Use -DENABLE_DEFAULT=OFF to disable components by default.
--
-- Configuring python-support support...
--   Dependency PYTHONLIBS_FOUND = TRUE
--   Dependency SWIG_FOUND = TRUE
--   Dependency SWIG_VERSION_CHECK = TRUE
--   Enabling python-support support.
--   Override with -DENABLE_PYTHON=ON/OFF
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.26")
-- checking for module 'cppunit'
--   found cppunit, version 1.12.1
-- Found CPPUNIT: /usr/lib/libcppunit.so;dl
--
-- Configuring testing-support support...
--   Dependency CPPUNIT_FOUND = TRUE
--   Enabling testing-support support.
--   Override with -DENABLE_TESTING=ON/OFF
--
-- Configuring volk support...
--   Enabling volk support.
--   Override with -DENABLE_VOLK=ON/OFF
-- Found PythonInterp: /usr/bin/python2 (found suitable version "2.7.3",
minimum required is "2")
--
-- Python checking for python >= 2.5
-- Python checking for python >= 2.5 - found
--
-- Python checking for Cheetah >= 2.0.0
-- Python checking for Cheetah >= 2.0.0 - found
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   filesystem
--   system
--   unit_test_framework
--   program_options
-- checking for module 'orc-0.4 > 0.4.11'
--   found orc-0.4 > 0.4.11, version 0.4.16
-- Found ORC: /usr/lib/x86_64-linux-gnu/liborc-0.4.so
-- Looking for cpuid.h
-- Looking for cpuid.h - found
-- Looking for intrin.h
-- Looking for intrin.h - not found
-- Looking for fenv.h
-- Looking for fenv.h - found
-- Looking for dlfcn.h
-- Looking for dlfcn.h - found
-- Compiler name: GNU
-- Performing Test HAVE_WERROR_UNUSED_CMD_LINE_ARG
-- Performing Test HAVE_WERROR_UNUSED_CMD_LINE_ARG - Failed
-- x86* CPU detected
-- Performing Test have_maltivec
-- Performing Test have_maltivec - Failed
-- Performing Test have_mfloat_abi_softfp
-- Performing Test have_mfloat_abi_softfp - Failed
-- Performing Test have_mfloat_abi_hard
-- Performing Test have_mfloat_abi_hard - Failed
-- Performing Test have_mfpu_neon
-- Performing Test have_mfpu_neon - Failed
-- Performing Test have_funsafe_math_optimizations
-- Performing Test have_funsafe_math_optimizations - Success
-- Performing Test have_m32
-- Performing Test have_m32 - Failed
-- Performing Test have_m64
-- Performing Test have_m64 - Success
-- Performing Test have_m3dnow
-- Performing Test have_m3dnow - Success
-- Performing Test have_msse4_2
-- Performing Test have_msse4_2 - Success
-- Performing Test have_mpopcnt
-- Performing Test have_mpopcnt - Success
-- Performing Test have_mmmx
-- Performing Test have_mmmx - Success
-- Performing Test have_msse
-- Performing Test have_msse - Success
-- Performing Test have_msse2
-- Performing Test have_msse2 - Success
-- Performing Test have_msse3
-- Performing Test have_msse3 - Success
-- Performing Test have_mssse3
-- Performing Test have_mssse3 - Success
-- Performing Test have_msse4a
-- Performing Test have_msse4a - Success
-- Performing Test have_msse4_1
-- Performing Test have_msse4_1 - Success
-- Performing Test have_mavx
-- Performing Test have_mavx - Success
-- Check size of void*[8]
-- Check size of void*[8] - done
-- CPU width is 64 bits, Overruled arch 32
-- Available architectures:
generic;64;3dnow;abm;popcount;mmx;sse;sse2;orc;norc;sse3;ssse3;sse4_a;sse4_1;sse4_2;avx
-- Available machines:
generic_orc;sse2_64_mmx_orc;sse3_64_orc;ssse3_64_orc;sse4_a_64_orc;sse4_1_64_orc;sse4_2_64_orc;avx_64_mmx_orc
-- BUILTTYPERELEASE
-- Base cflags = -O3 -DNDEBUG
-- BUILD INFO ::: generic_orc ::: GNU ::: -O3 -DNDEBUG
-- BUILD INFO ::: sse2_64_mmx_orc ::: GNU ::: -O3 -DNDEBUG  -m64 -mmmx
-msse -msse2
-- BUILD INFO ::: sse3_64_orc ::: GNU ::: -O3 -DNDEBUG  -m64 -mmmx -msse
-msse2 -msse3
-- BUILD INFO ::: ssse3_64_orc ::: GNU ::: -O3 -DNDEBUG  -m64 -mmmx
-msse
-msse2 -msse3 -mssse3
-- BUILD INFO ::: sse4_a_64_orc ::: GNU ::: -O3 -DNDEBUG  -m64 -mmmx
-msse
-msse2 -msse3 -msse4a -mpopcnt
-- BUILD INFO ::: sse4_1_64_orc ::: GNU ::: -O3 -DNDEBUG  -m64 -mmmx
-msse
-msse2 -msse3 -mssse3 -msse4.1
-- BUILD INFO ::: sse4_2_64_orc ::: GNU ::: -O3 -DNDEBUG  -m64 -mmmx
-msse
-msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -mpopcnt
-- BUILD INFO ::: avx_64_mmx_orc ::: GNU ::: -O3 -DNDEBUG  -m64 -mmmx
-msse
-msse2 -msse3 -mssse3 -msse4.1 -msse4.2 -mpopcnt -mavx
-- Compiler Version: cc (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3
Copyright (C) 2011 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is
NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR
PURPOSE.
-- Loading build date Wed, 09 Apr 2014 01:45:22 into constants...
-- Loading version 0.1 into constants...
-- Using install prefix: /usr/local
-- ENABLE_GR_LOG set to ON.
-- HAVE_LOG4CPP set to False.
-- LOG4CPP_LIBRARIES set to .
-- Found Doxygen: /usr/bin/doxygen (found version "1.7.6.1")
-- Could NOT find Sphinx (missing:  SPHINX_EXECUTABLE)
--
-- Configuring doxygen support...
--   Dependency DOXYGEN_FOUND = YES
--   Enabling doxygen support.
--   Override with -DENABLE_DOXYGEN=ON/OFF
--
-- Configuring sphinx support...
--   Dependency SPHINX_FOUND = FALSE
--   Disabling sphinx support.
--   Override with -DENABLE_SPHINX=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
-- Looking for C++ include netdb.h
-- Looking for C++ include netdb.h - found
-- Looking for C++ include sys/time.h
-- Looking for C++ include sys/time.h - found
-- Looking for C++ include sys/types.h
-- Looking for C++ include sys/types.h - found
-- Looking for C++ include sys/select.h
-- Looking for C++ include sys/select.h - found
-- Looking for C++ include sys/socket.h
-- Looking for C++ include sys/socket.h - found
-- Looking for C++ include io.h
-- Looking for C++ include io.h - not found
-- Looking for C++ include sys/mman.h
-- Looking for C++ include sys/mman.h - found
-- Looking for C++ include sys/ipc.h
-- Looking for C++ include sys/ipc.h - found
-- Looking for C++ include sys/shm.h
-- Looking for C++ include sys/shm.h - found
-- Looking for C++ include signal.h
-- Looking for C++ include signal.h - found
-- Looking for C++ include netinet/in.h
-- Looking for C++ include netinet/in.h - found
-- Looking for C++ include arpa/inet.h
-- Looking for C++ include arpa/inet.h - found
-- Looking for C++ include byteswap.h
-- Looking for C++ include byteswap.h - found
-- Looking for C++ include linux/ppdev.h
-- Looking for C++ include linux/ppdev.h - found
-- Looking for C++ include dev/ppbus/ppi.h
-- Looking for C++ include dev/ppbus/ppi.h - not found
-- Looking for C++ include unistd.h
-- Looking for C++ include unistd.h - found
-- Looking for C++ include malloc.h
-- Looking for C++ include malloc.h - found
-- Performing Test HAVE_SNPRINTF
-- Performing Test HAVE_SNPRINTF - Success
-- Performing Test HAVE_SIGACTION
-- Performing Test HAVE_SIGACTION - Success
-- Performing Test HAVE_SELECT
-- Performing Test HAVE_SELECT - Success
-- Performing Test HAVE_SYSCONF
-- Performing Test HAVE_SYSCONF - Success
-- Performing Test HAVE_GETPAGESIZE
-- Performing Test HAVE_GETPAGESIZE - Success
-- Performing Test HAVE_SSLEEP
-- Performing Test HAVE_SSLEEP - Failed
-- Performing Test HAVE_NANOSLEEP
-- Performing Test HAVE_NANOSLEEP - Success
-- Performing Test HAVE_GETTIMEOFDAY
-- Performing Test HAVE_GETTIMEOFDAY - Success
-- Performing Test HAVE_POSIX_MEMALIGN
-- Performing Test HAVE_POSIX_MEMALIGN - Success
-- Performing Test HAVE_VALLOC
-- Performing Test HAVE_VALLOC - Success
-- Performing Test HAVE_PTHREAD_SIGMASK
-- Performing Test HAVE_PTHREAD_SIGMASK - Success
-- Performing Test HAVE_CREATEFILEMAPPING
-- Performing Test HAVE_CREATEFILEMAPPING - Failed
-- Performing Test HAVE_SHM_OPEN
-- Performing Test HAVE_SHM_OPEN - Success
-- Performing Test HAVE_SINCOS
-- Performing Test HAVE_SINCOS - Success
-- Performing Test HAVE_SINCOSF
-- Performing Test HAVE_SINCOSF - Success
-- Performing Test HAVE_SINF
-- Performing Test HAVE_SINF - Success
-- Performing Test HAVE_COSF
-- Performing Test HAVE_COSF - Success
-- Performing Test HAVE_MMAP
-- Performing Test HAVE_MMAP - Success
-- Performing Test HAVE_PTHREAD_SETSCHEDPARAM
-- Performing Test HAVE_PTHREAD_SETSCHEDPARAM - Success
-- Performing Test HAVE_SCHED_SETSCHEDULER
-- Performing Test HAVE_SCHED_SETSCHEDULER - Success
--
-- Configuring gnuradio-runtime support...
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_VOLK = ON
--   Dependency PYTHONINTERP_FOUND = TRUE
--   Enabling gnuradio-runtime support.
--   Override with -DENABLE_GNURADIO_RUNTIME=ON/OFF
--   package 'Ice-3.5' not found
-- ICE 3.5 not found. Looking for 3.4
--   package 'Ice-3.4' not found
--
-- Configuring gr-ctrlport support...
--   Dependency Boost_FOUND = TRUE
--   Dependency SWIG_FOUND = TRUE
--   Dependency SWIG_VERSION_CHECK = TRUE
--   Dependency ICE_FOUND =
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Disabling gr-ctrlport support.
--   Override with -DENABLE_GR_CTRLPORT=ON/OFF
-- Looking for C++ include sys/resource.h
-- Looking for C++ include sys/resource.h - found
-- Loading build date Wed, 09 Apr 2014 01:45:27 into constants...
-- Loading version v3.7.x-xxx-xunknown into constants...
-- Looking for C++ include windows.h
-- Looking for C++ include windows.h - not found
-- TRY_SHM_VMCIRCBUF set to ON.
-- Looking for stdint.h
-- Looking for stdint.h - found
-- Looking for stddef.h
-- Looking for stddef.h - found
-- Check size of size_t
-- Check size of size_t - done
-- Check size of unsigned int
-- Check size of unsigned int - done
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
--
-- Configuring gr-blocks support...
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Enabling gr-blocks support.
--   Override with -DENABLE_GR_BLOCKS=ON/OFF
--
-- Python checking for python >= 2.5
-- Python checking for python >= 2.5 - found
--
-- Python checking for Cheetah >= 2.0.0
-- Python checking for Cheetah >= 2.0.0 - found
--
-- Python checking for lxml >= 1.3.6
-- Python checking for lxml >= 1.3.6 - found
--
-- Python checking for pygtk >= 2.10.0
-- Python checking for pygtk >= 2.10.0 - found
--
-- Python checking for numpy
-- Python checking for numpy - found
--
-- Configuring gnuradio-companion support...
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_PYTHON = ON
--   Dependency PYTHON_MIN_VER_FOUND = TRUE
--   Dependency CHEETAH_FOUND = TRUE
--   Dependency LXML_FOUND = TRUE
--   Dependency PYGTK_FOUND = TRUE
--   Dependency NUMPY_FOUND = TRUE
--   Enabling gnuradio-companion support.
--   Override with -DENABLE_GRC=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
--
-- Configuring gr-fec support...
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_GR_BLOCKS = ON
--   Enabling gr-fec support.
--   Override with -DENABLE_GR_FEC=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
-- checking for module 'fftw3f >= 3.0'
--   found fftw3f , version 3.3
-- Found FFTW3F: /usr/lib/libfftw3f.so
--
-- Configuring gr-fft support...
--   Dependency ENABLE_VOLK = ON
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_GR_BLOCKS = ON
--   Dependency FFTW3F_FOUND = TRUE
--   Enabling gr-fft support.
--   Override with -DENABLE_GR_FFT=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
--
-- Configuring gr-filter support...
--   Dependency ENABLE_VOLK = ON
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_GR_FFT = ON
--   Dependency ENABLE_GR_BLOCKS = ON
--   Enabling gr-filter support.
--   Override with -DENABLE_GR_FILTER=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
--
-- Configuring gr-analog support...
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_VOLK = ON
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_GR_FFT = ON
--   Dependency ENABLE_GR_FILTER = ON
--   Enabling gr-analog support.
--   Override with -DENABLE_GR_ANALOG=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
--
-- Configuring gr-digital support...
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_VOLK = ON
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_GR_FFT = ON
--   Dependency ENABLE_GR_FILTER = ON
--   Dependency ENABLE_GR_BLOCKS = ON
--   Dependency ENABLE_GR_ANALOG = ON
--   Dependency ENABLE_GR_BLOCKS = ON
--   Dependency ENABLE_GR_FILTER = ON
--   Enabling gr-digital support.
--   Override with -DENABLE_GR_DIGITAL=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
--
-- Configuring gr-atsc support...
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_GR_FFT = ON
--   Dependency ENABLE_GR_BLOCKS = ON
--   Dependency ENABLE_GR_FEC = ON
--   Dependency ENABLE_GR_FILTER = ON
--   Dependency ENABLE_GR_ANALOG = ON
--   Enabling gr-atsc support.
--   Override with -DENABLE_GR_ATSC=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
--
-- Configuring gr-audio support...
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Enabling gr-audio support.
--   Override with -DENABLE_GR_AUDIO=ON/OFF
-- checking for module 'alsa'
--   found alsa, version 1.0.25
-- Found ALSA 1.0.25
-- checking for module 'jack'
--   package 'jack' not found
-- Looking for C++ include AudioUnit/AudioUnit.h
-- Looking for C++ include AudioUnit/AudioUnit.h - not found
-- Looking for C++ include AudioToolbox/AudioToolbox.h
-- Looking for C++ include AudioToolbox/AudioToolbox.h - not found
-- checking for module 'portaudio'
--   package 'portaudio' not found
-- Could NOT find PORTAUDIO (missing:  PORTAUDIO_INCLUDE_DIRS
PORTAUDIO_LIBRARIES)
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
-- checking for module 'comedilib'
--   package 'comedilib' not found
--
-- Configuring gr-comedi support...
--   Dependency COMEDI_FOUND =
--   Dependency LINUX = TRUE
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Disabling gr-comedi support.
--   Override with -DENABLE_GR_COMEDI=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
--
-- Configuring gr-channels support...
--   Dependency ENABLE_VOLK = ON
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_GR_BLOCKS = ON
--   Dependency ENABLE_GR_FFT = ON
--   Dependency ENABLE_GR_FILTER = ON
--   Dependency ENABLE_GR_ANALOG = ON
--   Enabling gr-channels support.
--   Override with -DENABLE_GR_CHANNELS=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
--
-- Configuring gr-noaa support...
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_GR_BLOCKS = ON
--   Enabling gr-noaa support.
--   Override with -DENABLE_GR_NOAA=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
--
-- Configuring gr-pager support...
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_GR_FILTER = ON
--   Dependency ENABLE_GR_ANALOG = ON
--   Enabling gr-pager support.
--   Override with -DENABLE_GR_PAGER=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found
-- Found Qt4: /usr/bin/qmake (found suitable version "4.8.1", minimum
required is "4.2.0")
-- QWT Version: 5.2.2
-- Found Qwt: /usr/lib/libqwt-qt4.so
--
-- Python checking for PyQt4
-- Python checking for PyQt4 - found
--
-- Configuring gr-qtgui support...
--   Dependency Boost_FOUND = TRUE
--   Dependency QT4_FOUND = TRUE
--   Dependency QWT_FOUND = TRUE
--   Dependency ENABLE_VOLK = ON
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_GR_FFT = ON
--   Dependency ENABLE_GR_FILTER = ON
--   Dependency PYTHONLIBS_FOUND = TRUE
--   Dependency PYQT4_FOUND = TRUE
--   Enabling gr-qtgui support.
--   Override with -DENABLE_GR_QTGUI=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
--
-- Configuring gr-trellis support...
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_GR_ANALOG = ON
--   Dependency ENABLE_GR_BLOCKS = ON
--   Dependency ENABLE_GR_DIGITAL = ON
--   Enabling gr-trellis support.
--   Override with -DENABLE_GR_TRELLIS=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
-- checking for module 'uhd'
--   found uhd, version 003.006.002-64-g92b0b7ab
-- Found UHD: /usr/local/lib/libuhd.so
--
-- Configuring gr-uhd support...
--   Dependency Boost_FOUND = TRUE
--   Dependency UHD_FOUND = TRUE
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_GR_FILTER = ON
--   Dependency ENABLE_GR_BLOCKS = ON
--   Dependency ENABLE_GR_ANALOG = ON
--   Enabling gr-uhd support.
--   Override with -DENABLE_GR_UHD=ON/OFF
--
-- Configuring gr-utils support...
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_PYTHON = ON
--   Enabling gr-utils support.
--   Override with -DENABLE_GR_UTILS=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Found SDL:
/usr/lib/x86_64-linux-gnu/libSDL.so;/usr/lib/x86_64-linux-gnu/libSDLmain.a;-lpthread
(found version "1.2.14")
--
-- Configuring gr-video-sdl support...
--   Dependency SDL_FOUND = TRUE
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Enabling gr-video-sdl support.
--   Override with -DENABLE_GR_VIDEO_SDL=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
--
-- Configuring gr-vocoder support...
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_GR_FFT = ON
--   Dependency ENABLE_GR_BLOCKS = ON
--   Dependency ENABLE_GR_FILTER = ON
--   Dependency ENABLE_GR_ANALOG = ON
--   Enabling gr-vocoder support.
--   Override with -DENABLE_GR_VOCODER=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
-- checking for module 'libusb-1.0'
--   found libusb-1.0, version 1.0.9-rc3
-- Found libusb-1.0: /usr/include/libusb-1.0, /usr/lib/x86_64-linux-gnu/
libusb-1.0.so
--
-- Configuring gr-fcd support...
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_GR_BLOCKS = ON
--   Dependency ENABLE_GR_AUDIO = ON
--   Dependency LIBUSB_FOUND = TRUE
--   Enabling gr-fcd support.
--   Override with -DENABLE_GR_FCD=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
-- checking for module 'gsl >= 1.10'
--   found gsl , version 1.15
--
-- Configuring gr-wavelet support...
--   Dependency Boost_FOUND = TRUE
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_GR_BLOCKS = ON
--   Dependency ENABLE_GR_ANALOG = ON
--   Dependency GSL_FOUND = 1
--   Enabling gr-wavelet support.
--   Override with -DENABLE_GR_WAVELET=ON/OFF
-- Boost version: 1.48.0
-- Found the following Boost libraries:
--   date_time
--   program_options
--   filesystem
--   system
--   thread
--
-- Python checking for wx >= 2.8
-- Python checking for wx >= 2.8 - found
--
-- Python checking for numpy
-- Python checking for numpy - found
--
-- Configuring gr-wxgui support...
--   Dependency ENABLE_GNURADIO_RUNTIME = ON
--   Dependency ENABLE_GR_FFT = ON
--   Dependency ENABLE_GR_FILTER = ON
--   Dependency ENABLE_GR_ANALOG = ON
--   Dependency ENABLE_PYTHON = ON
--   Dependency NUMPY_FOUND = TRUE
--   Dependency WX_FOUND = TRUE
--   Enabling gr-wxgui support.
--   Override with -DENABLE_GR_WXGUI=ON/OFF
--
-- ######################################################
-- # Gnuradio enabled components
-- ######################################################
--   * python-support
--   * testing-support
--   * volk
--   * doxygen
--   * gnuradio-runtime
--   * gr-blocks
--   * gnuradio-companion
--   * gr-fec
--   * gr-fft
--   * gr-filter
--   * gr-analog
--   * gr-digital
--   * gr-atsc
--   * gr-audio
--   * gr-channels
--   * gr-noaa
--   * gr-pager
--   * gr-qtgui
--   * gr-trellis
--   * gr-uhd
--   * gr-utils
--   * gr-video-sdl
--   * gr-vocoder
--   * gr-fcd
--   * gr-wavelet
--   * gr-wxgui
--
-- ######################################################
-- # Gnuradio disabled components
-- ######################################################
--   * sphinx
--   * gr-ctrlport
--   * gr-comedi
--
-- Using install prefix: /usr/local
-- Building for version: v3.7.x-xxx-xunknown / 3.7.4git
-- Configuring done
-- Generating done
-- Build files have been written to: /home/ryjiao/git/gnuradio/build

BR

Jiao Xianjun(Ryan)
C539637020fd56193dd6daec746c4a84?d=identicon&s=25 Tom Rondeau (Guest)
on 2014-04-09 16:38
(Received via mailing list)
On Wed, Apr 9, 2014 at 12:36 AM, Jiao Xianjun <putaoshu@gmail.com>
wrote:

> [ 33%] Generating xor_bb_impl.h, xor_ss_impl.h, xor_ii_impl.h
> collect2: ld returned 1 exit status
>
> even if I use -lpthread explicitly.
>
> Anyone also encounter that? Thanks a lot!
>

Nope, not sure what's going on there. Ubuntu 12.04 uses glibc 2.13
(these
functions have been around since 2.3.4). We're including pthread.h in
that
file, cmake already sets up the links against pthread, and your cmake
shows
this:

-- Performing Test HAVE_PTHREAD_SIGMASK
-- Performing Test HAVE_PTHREAD_SIGMASK - Success
...
-- Performing Test HAVE_PTHREAD_SETSCHEDPARAM
-- Performing Test HAVE_PTHREAD_SETSCHEDPARAM - Success

So you're finding the right things. I'm running 12.04 on this machine
I'm
currently on and just built from that tarball myself with no problems.
Any
chance you've changed around your system at all that could have an
effect?

Tom
Cbe40b7bbc4cb5bacfa90a1f49288e99?d=identicon&s=25 Jiao Xianjun (Guest)
on 2014-04-13 04:58
(Received via mailing list)
Thanks for your clues.

I haven't solved it successfully.
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.