Forum: Ruby cucumber windows issue

56fc95b91c46868fb85b28b2548bbca4?d=identicon&s=25 John Berry (tucker1080)
on 2014-03-25 01:16
Hi All,

I'm having an issue when trying to run my cucumber scripts on a windows
7 machine.

Has anyone come across this issue before?
(Posted my gemlist and ruby version at the bottom.
(Also when I run bundle exec cucumber it complains that "cannot load
such file capybara"

Thanks

I get the message :

c:\project>cucumber
*** WARNING: You must use ANSICON 1.31 or higher
(https://github.com/adoxa/ansic
on/) to get coloured output on Windows
You have already activated multi_test 0.1.1, but your Gemfile requires
multi_tes
t 0.0.3. Prepending `bundle exec` to your command may solve this.
(Gem::LoadErro
r)
C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.5.3/lib/bundler/runtime.rb:34:in
`
block in setup'
C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.5.3/lib/bundler/runtime.rb:19:in
`
setup'
C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.5.3/lib/bundler.rb:119:in
`setup'
C:/Ruby193/lib/ruby/gems/1.9.1/gems/bundler-1.5.3/lib/bundler/setup.rb:7:in
`<to
p (required)>'
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in
`require'
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:60:in
`rescue in
require'
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:35:in
`require'
c:/website_overhaul/features/support/env.rb:2:in `<top (required)>'
C:/Ruby193/lib/ruby/gems/1.9.1/gems/cucumber-1.3.12/lib/cucumber/rb_support/rb_l
anguage.rb:95:in `load'
C:/Ruby193/lib/ruby/gems/1.9.1/gems/cucumber-1.3.12/lib/cucumber/rb_support/rb_l
anguage.rb:95:in `load_code_file'
C:/Ruby193/lib/ruby/gems/1.9.1/gems/cucumber-1.3.12/lib/cucumber/runtime/support
_code.rb:180:in `load_file'
C:/Ruby193/lib/ruby/gems/1.9.1/gems/cucumber-1.3.12/lib/cucumber/runtime/support
_code.rb:83:in `block in load_files!'
C:/Ruby193/lib/ruby/gems/1.9.1/gems/cucumber-1.3.12/lib/cucumber/runtime/support
_code.rb:82:in `each'
C:/Ruby193/lib/ruby/gems/1.9.1/gems/cucumber-1.3.12/lib/cucumber/runtime/support
_code.rb:82:in `load_files!'
C:/Ruby193/lib/ruby/gems/1.9.1/gems/cucumber-1.3.12/lib/cucumber/runtime.rb:184:
in `load_step_definitions'
C:/Ruby193/lib/ruby/gems/1.9.1/gems/cucumber-1.3.12/lib/cucumber/runtime.rb:42:i
n `run!'
C:/Ruby193/lib/ruby/gems/1.9.1/gems/cucumber-1.3.12/lib/cucumber/cli/main.rb:47:
in `execute!'
C:/Ruby193/lib/ruby/gems/1.9.1/gems/cucumber-1.3.12/bin/cucumber:13:in
`<top (re
quired)>'
C:/Ruby193/bin/cucumber:23:in `load'
C:/Ruby193/bin/cucumber:23:in `<main>'


GEM LIST


*** LOCAL GEMS ***

bigdecimal (1.1.0)
builder (3.2.2)
bundler (1.5.3)
capybara (2.2.1)
childprocess (0.5.1, 0.3.9)
cucumber (1.3.12, 1.3.10)
data_magic (0.16.1)
diff-lcs (1.2.5)
faker (1.2.0)
ffi (1.9.3 x86-mingw32)
gherkin (2.12.2 x86-mingw32)
i18n (0.6.9)
io-console (0.3)
json (1.5.5)
mime-types (2.2)
mini_portile (0.5.3)
minitest (2.5.1)
multi_json (1.8.4)
multi_test (0.1.1, 0.0.3)
nokogiri (1.6.1 x86-mingw32)
page-object (0.9.4)
page_navigation (0.9)
rack (1.5.2)
rack-test (0.6.2)
rake (0.9.2.2)
rdoc (3.9.5)
rspec (2.14.1)
rspec-core (2.14.7)
rspec-expectations (2.14.4)
rspec-mocks (2.14.4)
rubyzip (1.1.0)
selenium-webdriver (2.39.0)
watir-webdriver (0.6.4)
websocket (1.0.7)
xpath (2.0.0)
yml_reader (0.2)

c:\project>ruby -v
ruby 1.9.3p545 (2014-02-24) [i386-mingw32]
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.