Forum: Ruby on Rails Working with designmodo's Flat UI Pro

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
bertly_the_coder (Guest)
on 2014-03-02 16:47
(Received via mailing list)
Hi guys,

I am using Rails 4, Bootstrap 3 and simple_form  and have been having a
of trouble implementing Flat UI into my existing site. I used the
article to implement:
I tried to run my app, my first error was that typeahead.js was missing.
I went into the flatui.js file and removed this. Then I run the app
and this time it loaded. Now when I look at my radio-buttons, all they
is the label, when I click on them, I get a radio button, but it's
makes it look really cramped. When I click on another radio button, the
initial one showed disabled. How do I get to load the correct styling
first time? Am I missing a class designation? I've attached images:

fresh page:


clicked on one radio button:


clicked on second radio button:


Am I supposed to used classes to load and style correctly. I'm also
to style my selects which currently look like this:


My gem file looks correct with:

# Use SCSS for stylesheets

gem 'sass-rails', '~> 4.0.0'

gem 'jquery-ui-rails'

gem 'less-rails-bootstrap'

gem 'designmodo-flatuipro-rails'

gem 'therubyracer', platforms: :ruby

and my css file and js files include the following lines:
//= require jquery
//= require jquery.ui.button
//= require jquery.ui.datepicker
//= require jquery.ui.slider
//= require jquery.ui.spinner
//= require jquery.ui.tooltip
//= require jquery.ui.effect
//= require flatuipro
//= require jquery_ujs
//= require turbolinks
//= require bootstrap
//= require_tree .

Any help/pointers are highly appreciated.

Thank you!
This topic is locked and can not be replied to.