Forum: GNU Radio broken gnuplot

Aaa0fc4458ead49e4f9317634a32ae92?d=identicon&s=25 Nemanja Savic (Guest)
on 2014-02-25 12:50
(Received via mailing list)
Hi all guys,

lately I have experienced some problems with showing scope and fft plot.
Namely, the plots looks raw and ugly. Once there was an report that
gnuplot
was killed.

Any idea how to check and repair this?

Best,
B4ffbc711addde4c649b1ed526df6157?d=identicon&s=25 Martin Braun (Guest)
on 2014-02-25 13:15
(Received via mailing list)
On 02/25/2014 12:49 PM, Nemanja Savic wrote:
> Hi all guys,
>
> lately I have experienced some problems with showing scope and fft plot.
> Namely, the plots looks raw and ugly. Once there was an report that
> gnuplot was killed.
>
> Any idea how to check and repair this?

Are you using gnuplot?

What exactly are doing and which tools are you using?

M
Aaa0fc4458ead49e4f9317634a32ae92?d=identicon&s=25 Nemanja Savic (Guest)
on 2014-02-25 14:09
(Received via mailing list)
Attachment: Screenshot-1.png (50 KB)
_______________________________________________
Discuss-gnuradio mailing list
Discuss-gnuradio@gnu.org
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
C539637020fd56193dd6daec746c4a84?d=identicon&s=25 Tom Rondeau (Guest)
on 2014-02-25 15:03
(Received via mailing list)
On Tue, Feb 25, 2014 at 8:07 AM, Nemanja Savic <vlasinac@gmail.com>
wrote:

> So, it is default installation. I use RHEL6. Some time ago I uninstalled
> numpy due to installation of new version of matplotlib (I don't know if
> this is important).
> Now my gui looks like this
>

That's using wxPython, not gnuplot. It doesn't use matplotlib, either
(which depends on numpy, so if you installed matplotlib, you also still
have numpy). That will have no effect on the wxgui plots.

This is possibly related to opengl, though. You can turn that off by
editing $prefix/etc/gnuradio/conf.d/gr-wxgui.conf.

Tom
Aaa0fc4458ead49e4f9317634a32ae92?d=identicon&s=25 Nemanja Savic (Guest)
on 2014-02-25 15:36
(Received via mailing list)
Is there any way to repair this, because one or two months ago,
everything
was ok? Or, is there any log where I can figure what is the exact
problem?
C539637020fd56193dd6daec746c4a84?d=identicon&s=25 Tom Rondeau (Guest)
on 2014-02-25 16:21
(Received via mailing list)
On Tue, Feb 25, 2014 at 9:35 AM, Nemanja Savic <vlasinac@gmail.com>
wrote:
> Is there any way to repair this, because one or two months ago, everything
> was ok? Or, is there any log where I can figure what is the exact problem?

Well, since we don't know what you changed on your side, it's hard to
help you fix it. Again, numpy, matplotlib, and gnuplot have nothing to
do with this.

Have you tried my suggestion of turning opengl off? That tends to be
the main problem people have with using wxgui.

Tom
Aaa0fc4458ead49e4f9317634a32ae92?d=identicon&s=25 Nemanja Savic (Guest)
on 2014-02-25 23:46
(Received via mailing list)
Thank you Tom. I try tomorrow.
Aaa0fc4458ead49e4f9317634a32ae92?d=identicon&s=25 Nemanja Savic (Guest)
on 2014-02-26 12:24
(Received via mailing list)
When I use nongl option, then the gui looks like on the figure I posted,
and when I use gl option, the follosing error occures:
Traceback (most recent call last):
  File "/home/savi_ne/work/gnuradio/GRC/top_block.py", line 14, in
<module>
    from gnuradio.wxgui import fftsink2
  File
"/usr/local/lib64/python2.6/site-packages/gnuradio/wxgui/fftsink2.py",
line
34, in <module>
    raise RuntimeError("Unable to import OpenGL.  Are Python wrappers
for
OpenGL installed?")
RuntimeError: Unable to import OpenGL.  Are Python wrappers for OpenGL
installed?
C539637020fd56193dd6daec746c4a84?d=identicon&s=25 Tom Rondeau (Guest)
on 2014-02-26 18:29
(Received via mailing list)
On Wed, Feb 26, 2014 at 6:23 AM, Nemanja Savic <vlasinac@gmail.com>
wrote:
> RuntimeError: Unable to import OpenGL.  Are Python wrappers for OpenGL
> installed?

Ok, so definitely stick with the non-OpenGL version.

As to why it's stopped working for you, I can't say. Can you roll back
to an older version of GNU Radio that you know was working to see if
it's something there? If not, it's something with your system, and we
can't really be much help with that.

Tom
Aaa0fc4458ead49e4f9317634a32ae92?d=identicon&s=25 Nemanja Savic (Guest)
on 2014-05-08 18:21
(Received via mailing list)
Hi all again,

actually yes, the problem was due to numpy. Namely, I uninstalled 1.4.1
which I have on my RHEL6 and installed 1.5 or something. During that
opengl
was somehow deleted and when I installed using package manager, numpy
1.4.1
was installed again.

best
Aaa0fc4458ead49e4f9317634a32ae92?d=identicon&s=25 Nemanja Savic (Guest)
on 2014-05-12 11:25
(Received via mailing list)
If somebody have the same problem, just install pyopengl from source.
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.