Forum: Ruby-core Error downloading files from repository (.zip, .tar.gz, .tar.bz2, etc)

Bbc0993c96fac794d7525989fea9a00b?d=identicon&s=25 unknown (Guest)
on 2014-02-24 21:28
(Received via mailing list)
Issue #9561 has been updated by fabio pasini.


Some error logs

$ curl -O  http://cache.ruby-lang.org/pub/ruby/2.1/ruby-2.1.1.zip
  % Total    % Received % Xferd  Average Speed   Time    Time     Time
Current
                                 Dload  Upload   Total   Spent    Left
Speed
 99 15.8M   99 15.7M    0     0   330k      0  0:00:49  0:00:48  0:00:01
0

curl: (56) Failure when receiving data from the peer


$ wget http://cache.ruby-lang.org/pub/ruby/2.1/ruby-2.1.1.zip
--2014-02-24 17:13:34--
http://cache.ruby-lang.org/pub/ruby/2.1/ruby-2.1.1.zip
Resolvendo cache.ruby-lang.org... 199.27.72.184, 199.27.76.184
Conectando-se a cache.ruby-lang.org|199.27.72.184|:80... conectado.
A requisição HTTP foi enviada, aguardando resposta... 200 OK
Tamanho: 16618363 (16M) [application/zip]
Salvando em: "ruby-2.1.1.zip.1"
99% [================================================>  ] 16.487.269
--.-K/s   em 46s
O cabeçalho Last-modified é inválido -- horário ignorado.
2014-02-24 17:14:22 (350 KB/s) - Erro de leitura no byte
16487269/16618363 (Conexão fechada pela outra ponta).


----------------------------------------
Bug #9561: Error downloading files from repository (.zip, .tar.gz,
.tar.bz2, etc)
https://bugs.ruby-lang.org/issues/9561#change-45453

* Author: fabio pasini
* Status: Open
* Priority: Normal
* Assignee: Nobuyoshi Nakada
* Category: misc
* Target version:
* ruby -v: 2.1
* Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN, 2.1: UNKNOWN
This topic is locked and can not be replied to.