Forum: NGINX geoip_country_code header is deleted when I set another custom header

2974d09ac2541e892966b762aad84943?d=identicon&s=25 MarcPapers (Guest)
on 2014-01-10 10:40
(Received via mailing list)
Hello everybody.
I have a nginx (version: nginx/0.7.67) running as a loadbalancer for two
tomcat7 servers with the geoip module. It was working correctly until I
changed the configuration file placed in available-locations called
default
(we work only with the default one). The changes were made to detect
mobile
traffic and include a custom header. Changes are shown below:


## BEGIN DEFAULT ##

#--->content added after "server{"

server {
       set $mobile_flag NO;

## regex for determining if it is mobile traffic ##
if ($http_user_agent ~*
"(android|bb\d+|meego).+mobile|avantgo|bada\/|blackberry|blazer|compal|elaine|fennec|hiptop|iemobile|ip(hone|od)|iris|kindle|lge
|maemo|midp|mmp|netfront|opera m(ob|in)i|palm(
os)?|phone|p(ixi|re)\/|plucker|pocket|psp|series(4|6)0|symbian|treo|up\.(browser|link)|vodafone|wap|windows
(ce|phone)|xda|xiino") {
  set $mobile_flag YES;
}

if ($http_user_agent ~* "^(1207|6310|6590|3gso|4thp|50[1-6]i|770s|802s|a
wa|abac|ac(er|oo|s\-)|ai(ko|rn)|al(av|ca|co)|amoi|an(ex|ny|yw)|aptu|ar(ch|go)|as(te|us)|attw|au(di|\-m|r
|s
)|avan|be(ck|ll|nq)|bi(lb|rd)|bl(ac|az)|br(e|v)w|bumb|bw\-(n|u)|c55\/|capi|ccwa|cdm\-|cell|chtm|cldc|cmd\-|co(mp|nd)|craw|da(it|ll|ng)|dbte|dc\-s|devi|dica|dmob|do(c|p)o|ds(12|\-d)|el(49|ai)|em(l2|ul)|er(ic|k0)|esl8|ez([4-7]0|os|wa|ze)|fetc|fly(\-|_)|g1
u|g560|gene|gf\-5|g\-mo|go(\.w|od)|gr(ad|un)|haie|hcit|hd\-(m|p|t)|hei\-|hi(pt|ta)|hp(
i|ip)|hs\-c|ht(c(\-| |_|a|g|p|s|t)|tp)|hu(aw|tc)|i\-(20|go|ma)|i230|iac(
|\-|\/)|ibro|idea|ig01|ikom|im1k|inno|ipaq|iris|ja(t|v)a|jbro|jemu|jigs|kddi|keji|kgt(
|\/)|klon|kpt |kwc\-|kyo(c|k)|le(no|xi)|lg(
g|\/(k|l|u)|50|54|\-[a-w])|libw|lynx|m1\-w|m3ga|m50\/|ma(te|ui|xo)|mc(01|21|ca)|m\-cr|me(rc|ri)|mi(o8|oa|ts)|mmef|mo(01|02|bi|de|do|t(\-|
|o|v)|zz)|mt(50|p1|v
)|mwbp|mywa|n10[0-2]|n20[2-3]|n30(0|2)|n50(0|2|5)|n7(0(0|1)|10)|ne((c|m)\-|on|tf|wf|wg|wt)|nok(6|i)|nzph|o2im|op(ti|wv)|oran|owg1|p800|pan(a|d|t)|pdxg|pg(13|\-([1-8]|c))|phil|pire|pl(ay|uc)|pn\-2|po(ck|rt|se)|prox|psio|pt\-g|qa\-a|qc(07|12|21|32|60|\-[2-7]|i\-)|qtek|r380|r600|raks|rim9|ro(ve|zo)|s55\/|sa(ge|ma|mm|ms|ny|va)|sc(01|h\-|oo|p\-)|sdk\/|se(c(\-|0|1)|47|mc|nd|ri)|sgh\-|shar|sie(\-|m)|sk\-0|sl(45|id)|sm(al|ar|b3|it|t5)|so(ft|ny)|sp(01|h\-|v\-|v
)|sy(01|mb)|t2(18|50)|t6(00|10|18)|ta(gt|lk)|tcl\-|tdg\-|tel(i|m)|tim\-|t\-mo|to(pl|sh)|ts(70|m\-|m3|m5)|tx\-9|up(\.b|g1|si)|utst|v400|v750|veri|vi(rg|te)|vk(40|5[0-3]|\-v)|vm40|voda|vulc|vx(52|53|60|61|70|80|81|83|85|98)|w3c(\-|
)|webc|whit|wi(g |nc|nw)|wmlb|wonu|x700|yas\-|your|zeto|zte\-)") {
  set $mobile_flag YES;
}

...

#-->line added after "menosbasico;"

location / {
                proxy_pass http://xx;
                access_log  /var/log/nginx/xx.access.log menosbasico;
                proxy_set_header ismobiletraffic $mobile_flag;
        }

## END DEFAULT FILE ##

The proxy_set_header directive for geoip is placed in nginx.conf

## BEGIN NGINX.CONF ##

...
...

http {
    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;
    rewrite_log on;

    proxy_set_header X-Forwarded-For $remote_addr;

    geoip_country  /usr/share/GeoIP/GeoIP.dat;
    proxy_set_header GEOIP_COUNTRY_CODE $geoip_country_code;

...
...

## END NGINX.CONF ##

The problem is that now, the ismobiletraffic header is set correctly,
but
the geoip headers have disspeared from the request. Seems to have been
overwritten. Should I place the mobile traffic detection on NGINX.CONF
at
http{ } level? I have been looking for a solution but I didn't find
anything
helpful. Thanks in advance for your tips and advices!

Thanks,

Marcos.

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,246224,246224#msg-246224
2154be8b4430488454f0a067e09863b9?d=identicon&s=25 Ruslan Ermilov (Guest)
on 2014-01-10 11:38
(Received via mailing list)
On Fri, Jan 10, 2014 at 04:40:00AM -0500, MarcPapers wrote:
[...]
> ## BEGIN NGINX.CONF ##
>
> overwritten. Should I place the mobile traffic detection on NGINX.CONF at
> http{ } level? I have been looking for a solution but I didn't find anything
> helpful. Thanks in advance for your tips and advices!

It's expected and documented behavior:
http://nginx.org/r/proxy_set_header

: These directives are inherited from the previous level if and only if
: there are no proxy_set_header directives defined on the current level.
2974d09ac2541e892966b762aad84943?d=identicon&s=25 MarcPapers (Guest)
on 2014-01-10 11:57
(Received via mailing list)
Thanks Ruslan, obviously at the level(http server) that I was setting
the
mobile header, it didn't use to inherit the geoip header because it was
set
in a previous level (nginx configuration). I didn't see it. Thanks for
your
help. What I did for doing it work properly was adding the geoip at the
same
level, resulting like that:

location / {
                proxy_pass http://xx;
                access_log  /var/log/nginx/xx.access.log menosbasico;
                proxy_set_header GEOIP_COUNTRY_CODE $geoip_country_code;
                proxy_set_header ismobiletraff $mobile_flag;
        }

Thank you very much!

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,246224,246230#msg-246230
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.