Forum: NGINX mainline does not include gzip module?

2974d09ac2541e892966b762aad84943?d=identicon&s=25 ura (Guest)
on 2014-01-04 02:24
(Received via mailing list)
i just replaced a stable install with the mainline version (1.5.8) and
noticed that the outputted files are not being gzipped.
i ran nginx -V and do not see any arguments that enable gzip.
is there a reason why the stable version included gzip and this mainline
does not?
do i need to manually build nginx to include the gzip module?
if so, does that mean i need to rebuild nginx every time there is a new
update?
thanks

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,245997,245997#msg-245997
40b4c848b8fcd63b0cb60b9d170c3a77?d=identicon&s=25 Valentin V. Bartenev (Guest)
on 2014-01-04 02:34
(Received via mailing list)
On Friday 03 January 2014 20:22:28 ura wrote:
> i just replaced a stable install with the mainline version (1.5.8) and
> noticed that the outputted files are not being gzipped.
> i ran nginx -V and do not see any arguments that enable gzip.
> is there a reason why the stable version included gzip and this mainline
> does not?

The gzip module is compiled by default, unless explicitly disabled
using the --without-http_gzip_module argument.

> do i need to manually build nginx to include the gzip module?

No, you don't.  It is included in both packages stable and mainline.

  wbr, Valentin V. Bartenev
2974d09ac2541e892966b762aad84943?d=identicon&s=25 ura (Guest)
on 2014-01-04 02:52
(Received via mailing list)
thanks for responding. :)

so... has a change been made in the way i would activate the gzip
process
between the stable and mainline versions?
in nginx.conf?

this is the list of options i was successfully using in stable (built
through trial and error):
    gzip on;
    gzip_http_version 1.0;
    gzip_comp_level 6;
    gzip_proxied any;
    gzip_min_length  100;
    gzip_buffers 16 8k;
    gzip_types text/plain text/css application/x-javascript
application/json
text/xml application/xml application/xml+rss text/javascript;
    gzip_disable "msie6";
    gzip_vary on;

any other thoughts on why gzip would appear to not be functioning for me
here?

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,245997,245999#msg-245999
2974d09ac2541e892966b762aad84943?d=identicon&s=25 ura (Guest)
on 2014-01-04 02:53
(Received via mailing list)
ah, i found the answer..
i needed to change the javascript mimetype to 'application/javascript'

Posted at Nginx Forum:
http://forum.nginx.org/read.php?2,245997,246000#msg-246000
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.