Forum: GNU Radio OutOfTree Module Tutorial

784aeab67945cc81a91452c4b26dcd6d?d=identicon&s=25 Tanaga Biru (Guest)
on 2014-01-01 14:53
(Received via mailing list)
Dear Helpers,

I am using GNURadio 3.6.4.1. I am following the tutorial on
OutOfTreeModules
http://gnuradio.org/redmine/projects/gnuradio/wiki.... I
am
having trouble in running make test. It fails with

Traceback (most recent call last):
2:   File "/home/lilo/workspace/gr-howto/python/qa_square_ff.py", line
38,
in test_001_square_ff
2:     src = blocks.vector_source_f(src_data)
2: AttributeError: 'module' object has no attribute 'vector_source_f'

Is the tutorial compatible with my GNURadio version? Or am I missing
something?

Thank you in advance.

Regards,
Tanaga Biru
7d89a70df32c0ae27c1235016f9e5441?d=identicon&s=25 "Marcus Müller" <marcus@hostalia.de> (Guest)
on 2014-01-01 14:57
(Received via mailing list)
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi Tanaga,

no, the tutorial is not compatible with your GR version.
3.6.4 is *really* old; please use the current versions (3.7) if you
want to develop your own GNU Radio modules.
However, if I may ask: How, where and why did you get 3.6.4.1?

Happy hacking,
Marcus

On 01.01.2014 14:52, Tanaga Biru wrote:
> AttributeError: 'module' object has no attribute 'vector_source_f'
> _______________________________________________ Discuss-gnuradio
> mailing list Discuss-gnuradio@gnu.org
> https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQEcBAEBAgAGBQJSxB5hAAoJEAFxB7BbsDrLwagIAJsnCPuXy+kjJFMSB0xFSEZS
RYxQ28mKoBN6JJe5VFMzpSwIG4dTckev7hiYyTBWCvoFJvWtp9E1c3pYK5A/QfLu
0DZz9ORc2V+iMowEgF+6Rh4+ArIS9sGoB9b3TtHpCru5IJ8XGPKSkL2iNpsmgvoA
0tPDwQdwpiIxYl1BE8EBTajCwq03pVI0newi6KR9wl3oTBTcdx3bZptmbJnAqWsE
mtyOzUtdgkrzpagFdPoyYLkV2pNI1ean7j6i9GD1glN2JeyJo8vr9vkuIKT847B0
CulZhCDQZ0x+JM6d+Vsx0M46qlo/mRBrkRb7XOuzHgpblca2n8Nk1geKwMfPr4k=
=YunE
-----END PGP SIGNATURE-----
3ec7416d05ec361ffca57205ad5d6289?d=identicon&s=25 rishabhdabral (Guest)
on 2014-05-20 23:18
(Received via mailing list)
No, your version is not compatible. You can either change your version.
Or,
try the following change:

In your code, instead of using /blocks.vector_source_f()/ use
/gr.vector_source_f()/ Apply this change to both, the source as well as
sink
definition.

HTH,
Rishabh Dabral




--
View this message in context:
http://gnuradio.4.n7.nabble.com/OutOfTree-Module-T...
Sent from the GnuRadio mailing list archive at Nabble.com.
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.