Forum: Ruby on Rails Cannot run second rails app in second domain (in vps)

Be6584d65dc1fd7a0a7c52c38d0e677b?d=identicon&s=25 "Fernando Segura Gòmez" <angelusfer@gmail.com> (Guest)
on 2013-12-21 12:50
(Received via mailing list)
Hi for everyone.
I have a problem with my vps and my app in rails.
A few months I constructed an app with rails, in my vps, the application
is
working fine, without any problem, i working with a version 4.0 and the
version for ruby is 1.9.3.
In a second domain, i installed the same version for both (ruby and
rails),
and run the application without any problem, in port 3000(the first is
in
3005) but when i try to load in my browser, nothing happened ( run the
app
in this way : www.mydomain.com:3000 ), no load,no showing error in my
ssh
client.What's going on?.
I thought that my app was wrong, that's why delete the folder and build
a
new blank rails project, but when i run ( my domain is
www.mydomain.com/app:3000) nothing happen, not load the website.

What can be the problem?
52f3528c40e9cf28ad0900886eecb128?d=identicon&s=25 Jordon Bedwell (Guest)
on 2013-12-21 13:09
(Received via mailing list)
On Sat, Dec 21, 2013 at 5:34 AM, Fernando Segura Gmez
<angelusfer@gmail.com> wrote:
> new blank rails project, but when i run ( my domain is
> www.mydomain.com/app:3000) nothing happen, not load the website.
>
> What can be the problem?

How about you provide more information on the server operating system
and distribution and the hosting provider.  We can't magically guess
these diagnostically relevant pieces of information that would let us
know if it's your fault for misconfiguring or if we should point you
in other directions.
46f52c33235283752423837b91c581dd?d=identicon&s=25 Norm Scherer (Guest)
on 2013-12-21 17:34
(Received via mailing list)
Can you access it locally on your vps? I would give a try with something
like curl or lynx (both text based accsess).  Run one of them from a
terminal and see if you can get the initial root page whatever that is.
If that works you have a communication problem (firewall maybe).  If it
does not work look in your logs.

Norm
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.