Forum: Ruby on Rails Sass caching issue in development.

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
3baf5cfbd296c30d6ca7755bca48e463?d=identicon&s=25 Mathias Jean Johansen (Guest)
on 2013-11-14 22:59
(Received via mailing list)
Hi everyone,

Lately, I've had quite an annoying problem when I work with Sass in
Rails.
For reasons I cannot figure out, I need to kill the local Rails server
instance, "rm -rf tmp/cache" and start the server again to see the
changes
I've made in app/assets/stylesheets. It obviously affects my
productivity
why I now seek your help.

Many answers on StackOverflow to similar questions suggest that I add
config.assets.cache_store
= :null_store and config.sass.cache = false to
config/environments/development.rb, but unfortunately that does not help
me
solve my problem. Other answers suggest that I remove tmp/cache which
works
in my case, but the problem is that I have to do it every single time I
change something in app/assets/stylesheets.

I run Ruby 1.9.3p448 (2013-06-27 revision 41675) [x86_64-darwin13.0.0]
and Rails 3.2.15 on Mac OS 10.9.

I really hope that some of you might have a solution to my problem.

Kind regards,
Mathias Jean Johansen
0eb3bd82b3d2d5bdf725e59467efdb18?d=identicon&s=25 unknown (Guest)
on 2014-01-06 20:39
(Received via mailing list)
Mathias,

Did you ever find a solution? A few people at my work including myself
also
have the same issue.

Eric

On Thursday, November 14, 2013 12:46:50 AM UTC-7, Mathias Jean Johansen
This topic is locked and can not be replied to.