Forum: Ruby on Rails rails generate scaffold - ERROR

Fcd2b2ca6e9b8c75069a291665869ab9?d=identicon&s=25 Natmanu (Guest)
on 2013-10-23 16:39
(Received via mailing list)
Hi,

I just installed ROR using the rvm using these instructions:
http://ryanbigg.com/2010/12/ubuntu-ruby-rvm-rails-and-you/

Using Ubuntu 12 on VirtualBox

I'm trying to create a demo_app

rails generate scaffold User name:string email:string

gives me this error:
--
/home/natmanu/.rvm/gems/ruby-2.0.0-p247/gems/execjs-2.0.2/lib/execjs/runtimes.rb:51:in
`autodetect': Could not find a JavaScript runtime. See
https://github.com/sstephenson/execjs for a list of available runtimes.
(ExecJS::RuntimeUnavailable)
    from
/home/natmanu/.rvm/gems/ruby-2.0.0-p247/gems/execjs-2.0.2/lib/execjs.rb:5:in
`<module:ExecJS>'
    from
/home/natmanu/.rvm/gems/ruby-2.0.0-p247/gems/execjs-2.0.2/lib/execjs.rb:4:in
`<top (required)>'
    from
/home/natmanu/.rvm/gems/ruby-2.0.0-p247/gems/uglifier-2.1.1/lib/uglifier.rb:3:in
`require'
    from
/home/natmanu/.rvm/gems/ruby-2.0.0-p247/gems/uglifier-2.1.1/lib/uglifier.rb:3:in
`<top (required)>'
    from
/home/natmanu/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.5/lib/bundler/runtime.rb:72:in
`require'
    from
/home/natmanu/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.5/lib/bundler/runtime.rb:72:in
`block (2 levels) in require'
    from
/home/natmanu/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.5/lib/bundler/runtime.rb:70:in
`each'
    from
/home/natmanu/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.5/lib/bundler/runtime.rb:70:in
`block in require'
    from
/home/natmanu/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.5/lib/bundler/runtime.rb:59:in
`each'
    from
/home/natmanu/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.5/lib/bundler/runtime.rb:59:in
`require'
    from
/home/natmanu/.rvm/gems/ruby-2.0.0-p247@global/gems/bundler-1.3.5/lib/bundler.rb:132:in
`require'
    from /home/natmanu/Sites/microblog/config/application.rb:7:in `<top
(required)>'
    from
/home/natmanu/.rvm/gems/ruby-2.0.0-p247/gems/railties-4.0.0/lib/rails/commands.rb:44:in
`require'
    from
/home/natmanu/.rvm/gems/ruby-2.0.0-p247/gems/railties-4.0.0/lib/rails/commands.rb:44:in
`<top (required)>'
    from bin/rails:4:in `require'
    from bin/rails:4:in `<main>'

Any helpers?

TIA NAT
A47e0a6beeb9d048ff054fc1c3a97418?d=identicon&s=25 Walter Davis (walterdavis)
on 2013-10-23 17:52
(Received via mailing list)
And what do you see at this URL?

Walter
C913fb845c78f595363b31813fbf18ca?d=identicon&s=25 Nate West (Guest)
on 2013-10-23 18:11
(Received via mailing list)
Hey Natmanu,

In order for Rails assets pipeline to handle JS it needs a JS runtime
installed on your machine. Since you said you're on Ubuntu if you don't
mind installing node you could just run sudo apt-get install nodejs.
Otherwise the execjs gem works well and makes your project a little more
portable.

-- Nate West <http://about.me/natewest> --
-615.631.6545-
Fcd2b2ca6e9b8c75069a291665869ab9?d=identicon&s=25 Natmanu (Guest)
on 2013-10-25 11:13
(Received via mailing list)
I'm new to ubuntu, only installed it to learn ruby.

Is there a comand to install

On Wednesday, 23 October 2013 16:10:45 UTC, Nate West wrote:
> -615.631.6545-
>
>
> Thanks Nate,  I managed to get  the JS installed.
98156ca4d9d9229a2c967005966e8903?d=identicon&s=25 greatghoul (Guest)
on 2013-10-25 11:19
(Received via mailing list)
Uncomment the following line in Gemfile

# gem 'therubyracer', :platforms => :ruby



On Fri, Oct 25, 2013 at 5:12 PM, Natmanu <natmanu@gmail.com> wrote:

>> installed on your machine. Since you said you're on Ubuntu if you don't
>
>>>
>>> For more options, visit
https://groups.google.com/**groups/opt_out<https:/...
>
https://groups.google.com/d/msgid/rubyonrails-talk...
> .
>
> For more options, visit https://groups.google.com/groups/opt_out.
>



--
 *greatghoul <http://www.g2w.me> - Ask and Learn!*
Fcd2b2ca6e9b8c75069a291665869ab9?d=identicon&s=25 Natmanu (Guest)
on 2013-10-25 11:19
(Received via mailing list)
Hi,

I seem to be hitting some configuration errors every step of the
tutorial.
 IS there a way to check my config to see I have all that I need set up?

Now when I try:  bundle exec rake db:migrate

is get Error:   RVM Ruby not used, run 'rvm use 1.9.1' first

I'm not sure i understand the error. is should run: rvm use 1.9.1

...I'm persevering... :-)
nat
5f94b9b346c2aa648a80bc259978e5bc?d=identicon&s=25 Colin Law (Guest)
on 2013-10-25 11:36
(Received via mailing list)
On 25 October 2013 10:18, Natmanu <natmanu@gmail.com> wrote:
> Hi,
>
> I seem to be hitting some configuration errors every step of the tutorial.
> IS there a way to check my config to see I have all that I need set up?
>
> Now when I try:  bundle exec rake db:migrate
>
> is get Error:   RVM Ruby not used, run 'rvm use 1.9.1' first
>
> I'm not sure i understand the error. is should run: rvm use 1.9.1

I sympathise with you, trying to learn Ubuntu, rvm, ruby and rails all
at once can be a bit overwhelming.  Persevere and all will become
clear in time.  The error seems a bit odd.  The rvm use command allows
you to specify which ruby you wish to use, I am surprised that it has
not defaulted to something.  However you can easily set the default
ruby.  First see which ones you have installed by running, in a
terminal
rvm list

Then to make one of the these the default run
rvm --default use 1.9.3
you don't normally need the -pnnn patch number unless you have
multiple versions of the same ruby (which would not normally be a good
idea).  In the error it said 1.9.1, I hope you are not using that
version (which does not play well with rails), it should probably be
1.9.3

Colin
Fcd2b2ca6e9b8c75069a291665869ab9?d=identicon&s=25 Natmanu (Guest)
on 2013-10-25 12:51
(Received via mailing list)
Thanks for the reply Colin,

I'm sure my stubborn nature is going to get me through this learning
curve.

when i run: rvm list

the result is:

ruby-2.0.0-p247 [x86_64]
# => - current
# =* - current && default
# * - default


So should i run
rvm --default use 1.9.3
or
rvm --default use 2.0.0

Nat
5f94b9b346c2aa648a80bc259978e5bc?d=identicon&s=25 Colin Law (Guest)
on 2013-10-25 13:02
(Received via mailing list)
On 25 October 2013 11:49, Natmanu <natmanu@gmail.com> wrote:
> Thanks for the reply Colin,

No, problem.  Could you not top post please, it makes it difficult to
follow the thread.  Insert your reply at appropriate points in
previous message.  Thanks.

> # * - default
>
>
> So should i run
> rvm --default use 1.9.3
> or
> rvm --default use 2.0.0

rvm list says you only have 2.0.0 installed, which I see is the one
recommended in the tutorial so that should be ok, so
rvm --default use 2.0.0
Then when you run rvm list again you see it with =* against it showing
that it is the current and default.

Looking at the tutorial I see that Ryan has included the command to
set the default in the section headed Ruby, presumably you missed that
bit.

Colin
Fcd2b2ca6e9b8c75069a291665869ab9?d=identicon&s=25 Natmanu (Guest)
on 2013-10-25 15:10
(Received via mailing list)
Thanks for the help and direction on posting Colin.

I've managed to get it working now.. well i did not get an error when
running db:migrate

Think I need  break. Will continue later and sure you'll see me around
here
agian.
Cheers Colin and all who replied.

Nat
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.