Forum: JRuby Jruby 1.7.4 not working with Heroku

2d1b64aaf61046ad166db3009fa8c7dc?d=identicon&s=25 Charles Monteiro (Guest)
on 2013-10-11 19:28
(Received via mailing list)
here's what Heroku spits back when I try to push my app up,

Total 16 (delta 0), reused 0 (delta 0)

-----> Ruby/Rack app detected
 !
 !     Invalid RUBY_VERSION specified: ruby-2.0.0-jruby-1.7.4
 !     Valid versions: ruby-2.0.0, ruby-1.9.3, ruby-1.9.2, ruby-1.8.7,
ruby-1.9.3-jruby-1.7.0, ruby-1.8.7-jruby-1.7.0, ruby-1.9.3-jruby-1.7.1,
ruby-1.8.7-jruby-1.7.1, ruby-1.9.3-rbx-2.0.0dev, ruby-1.8.7-rbx-2.0.0dev
 !

 !     Push rejected, failed to compile Ruby/Rack app


the latest Jruby supported apparently is Jruby 1.7.1 ?

Is this a political thing ? does EngineYard support the latest ? The
great thing about heroku though is that I can do dev work for basically
free



Charles\
40e5e9fe36a1f85166493faac2c17499?d=identicon&s=25 Hirotsugu Asari (Guest)
on 2013-10-11 19:52
(Received via mailing list)
Attachment: signature.asc (494 Bytes)
On Oct 11, 2013, at 1:26 PM, Charles Monteiro <jruby@smallruby.com>
wrote:

> !     Push rejected, failed to compile Ruby/Rack app
>
>
> the latest Jruby supported apparently is Jruby 1.7.1 ?
>
> Is this a political thing ? does EngineYard support the latest ? The great thing
about heroku though is that I can do dev work for basically free

You'll need to ask Heroku. There is no politics involved here. Heroku
and Engine Yard make their own decisions when it comes what versions of
JRuby to support.

Hiro
5c6727e573b7be20dea6a6880856a888?d=identicon&s=25 Mike Pence (Guest)
on 2013-10-11 19:56
(Received via mailing list)
That error message is misleading. This works for me (in Gemfile)

ruby '1.9.3', :engine => 'jruby', :engine_version => '1.7.5'
2d1b64aaf61046ad166db3009fa8c7dc?d=identicon&s=25 Charles Monteiro (Guest)
on 2013-10-11 20:00
(Received via mailing list)
ok, I'll try that , still a drag since I have moved on to use 2.0 named
arg syntax

Charles
5c6727e573b7be20dea6a6880856a888?d=identicon&s=25 Mike Pence (Guest)
on 2013-10-11 20:03
(Received via mailing list)
2.0 should work as well. I will verify.
5c6727e573b7be20dea6a6880856a888?d=identicon&s=25 Mike Pence (Guest)
on 2013-10-11 20:06
(Received via mailing list)
Confirmed:

-----> Using Ruby version: ruby-2.0.0-jruby-1.7.5
2d1b64aaf61046ad166db3009fa8c7dc?d=identicon&s=25 Charles Monteiro (Guest)
on 2013-10-11 20:11
(Received via mailing list)
yes , I can reconfirm that as well !

but this :

ruby '2.0.0', :engine => 'jruby', :engine_version => '1.7.4'

gives me this:

----> Ruby/Rack app detected
 !
 !     Invalid RUBY_VERSION specified: ruby-2.0.0-jruby-1.7.4
 !     Valid versions: ruby-2.0.0, ruby-1.9.3, ruby-1.9.2, ruby-1.8.7,
ruby-1.9.3-jruby-1.7.0, ruby-1.8.7-jruby-1.7.0, ruby-1.9.3-jruby-1.7.1,
ruby-1.8.7-jruby-1.7.1, ruby-1.9.3-rbx-2.0.0dev, ruby-1.8.7-rbx-2.0.0dev
 !

 !     Push rejected, failed to compile Ruby/Rack app


guess its time to move up to 1.7.5 :)


Charles Monteiro
jruby@smallruby.com
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.