Forum: Ruby on Rails Omni_auth with Facebook

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
E87acb6dd8c56899ff41fc0e54ea19ec?d=identicon&s=25 Rosy Catz (rosy)
on 2013-10-07 16:36
Hi,

  I've implemented the sample app with omni_auth('0.2.6'). I'm using
rails 2.3.11 with ruby 1.8.7. I tried to connect with Facebook but
getting oauth error. I tested it with twitter & google plus account.
Both are working fine but the FB connects is not working yet. Can you
please help me out?.
280b78a61a968391b7e07e912be102a8?d=identicon&s=25 Robert Walker (robert4723)
on 2013-10-07 23:27
Rosy Catz wrote in post #1123747:
> Hi,
>
>   I've implemented the sample app with omni_auth('0.2.6'). I'm using
> rails 2.3.11 with ruby 1.8.7. I tried to connect with Facebook but
> getting oauth error. I tested it with twitter & google plus account.
> Both are working fine but the FB connects is not working yet. Can you
> please help me out?.

AFAIK Facebook is currently using OAuth 2. Since you're using such an
old version of Rails and OmniAuth are you sure the are still compatible
with Facebook?

I use OmniAuth myself, but not with Facebook, and I use the current
version of OmniAuth on Rails 4.0.
E87acb6dd8c56899ff41fc0e54ea19ec?d=identicon&s=25 Rosy Catz (rosy)
on 2013-10-08 07:46
Well Thanks for your reply. Atually i want to integrate this omni-auth
with my existing rails 2.3 project so only tried with sample. The file
omniauth.rb under initializers is not accepting getting issue for
"ActionController::Dispatcher". Can you please
help me what i missed?.

Robert Walker wrote in post #1123794:
> Rosy Catz wrote in post #1123747:
>> Hi,
>>
>>   I've implemented the sample app with omni_auth('0.2.6'). I'm using
>> rails 2.3.11 with ruby 1.8.7. I tried to connect with Facebook but
>> getting oauth error. I tested it with twitter & google plus account.
>> Both are working fine but the FB connects is not working yet. Can you
>> please help me out?.
>
> AFAIK Facebook is currently using OAuth 2. Since you're using such an
> old version of Rails and OmniAuth are you sure the are still compatible
> with Facebook?
>
> I use OmniAuth myself, but not with Facebook, and I use the current
> version of OmniAuth on Rails 4.0.
This topic is locked and can not be replied to.