Forum: NGINX nginx config: different projects in different directories

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Bc3cbbdadcf7485288e502d084820c32?d=identicon&s=25 Jabba Laci (Guest)
on 2013-10-07 07:28
(Received via mailing list)
Hi,

I'm new to the list. I started to learn the Python web framework Flask
and I would like to try it in production environment too. I managed to
bring Flask together with uwsgi and nginx. My Flask application is
available at the address localhost:81 .

I would like to add several applications and I want them to be
available under different URLs. For instance, if I have two projects
called "hello" and "world", I want to access them as
localhost:81/hello/ and localhost:81/world/ . The problem is I can't
figure out how to configure nginx for this.

Here is my current setup:

* The project "hello" is in this directory:
/home/jabba/public_pyapps/hello/
* Its nginx entry:

server {
    listen      81;
    server_name localhost;
    charset     utf-8;
    client_max_body_size 75M;

    location / { try_files $uri @yourapplication; }
    location @yourapplication {
        include uwsgi_params;
        uwsgi_pass
unix:/home/jabba/public_pyapps/hello/hello_uwsgi.sock;
    }
}

It's available at localhost:81 .

Questions:

(1) How to make it available under localhost:81/hello/ instead?

(2) If I add a new application (e.g. "world") next to previous ones,
how to add it to nginx?

Thanks,

Laszlo
B6e666ac45ee856f0dcd07da8dfb30e2?d=identicon&s=25 Ruben LZ Tan (Guest)
on 2013-10-07 07:40
(Received via mailing list)
Maybe try setting location /hello and /world would help?

Thanks,
Ruben Tan
Bc3cbbdadcf7485288e502d084820c32?d=identicon&s=25 Jabba Laci (Guest)
on 2013-10-07 07:51
(Received via mailing list)
> Maybe try setting location /hello and /world would help?

I tried that but it didn't work.

Laszlo
This topic is locked and can not be replied to.