Forum: GNU Radio No audio block working in fresh install of 3.7.2 on virgin Debian system

F762b223a87f868db769f9a297fe976c?d=identicon&s=25 Mike W. (mike_w)
on 2013-10-05 11:05
I have installed a completely fresh version of Debian Wheezy on my Dell
E4310 Laptop. I have also installed gnuradio via pyboms from the main
distribution last night, as recommended. I also installed gr-fcd.

This is pretty basic and should simply just work. However, the fcd block
does not operate (I have included the udev rule) even the simple
dialtone will not work.

Dialtone gives "RuntimeError: audio_oss_sink" resulting from not being
able to open the audio device. This should be detected automatically but
the result is "audio_oss_sink: /dev/dsp: no such file or directory".
Well that's fine as there is no /dev/dsp. Remember this is a deafult
install of Wheezy.

However, I have tried every combination of hw:N,N and the same for
plughw without success. The result is always something like hw:0 No such
file or directory.

I suspect there is something missing from the default installation but
sound works fine in other applications.
F762b223a87f868db769f9a297fe976c?d=identicon&s=25 Mike W. (mike_w)
on 2013-10-05 19:44
update - I discover that Wheezy does not have OSS because it is
deprecated. Why is gnuradio 3.7.2 trying to use oss anyway when it
should be using alsa? Come on, this should just work, its one of the
most basic examples.
F762b223a87f868db769f9a297fe976c?d=identicon&s=25 Mike W. (mike_w)
on 2013-10-06 18:57
Mike W. wrote in post #1123627:
> update - I discover that Wheezy does not have OSS because it is
> deprecated. Why is gnuradio 3.7.2 trying to use oss anyway when it
> should be using alsa? Come on, this should just work, its one of the
> most basic examples.


I needed to get this working so I thought I would spend a few hours
today searching for solutions and advice via the documentation. I must
say I am disappointed there is nobody with any advice on this issue.
There was nothing obviously wrong, so I re-started from scratch. It took
me 4 hours but it did not result in any progress.

I wiped the Wheezy install and did a fresh vanilla install. I have
installed nothing else other than the standard distribution, git and
sudo.

I then cloned Pybombs and did the ./pybombs install gnuradio and tried a
simple GRC test. An audio source with a scope sink. I get exactly the
same negative results.

The runtime error response is:

          audio_oss_source: /dev/dsp: No such file or directory

Now this is not surprising as Debian is using ALSA for sound, which is
working fine on this laptop. There is no /dev/dsp directory because
there is no OSS. OSS has been expunged from the linux kernel. Norwegian
Blue parrot style.

The documentation says quite clearly to leave the device name blank to
choose the default audio device and instructs ALSA users with issues to
use plughw:0,0. This results in the same problem. There are no options
to use ALSA or OSS or Pulse.

I can only conclude either Wheezy, or Pybombs or Gnuradio is broken. I
suspect it is Gnuradio.

Mike
F762b223a87f868db769f9a297fe976c?d=identicon&s=25 Mike W. (mike_w)
on 2013-10-07 19:26
Yet more non-progress today.

Firstly, I downloaded the Ubuntu live CD with Gnuradio (24hrs) and it
worked!

So, I have downloaded Ubuntu 12.04LTS, Git and Pybombs. Installed
Gnuradio again. Guess what? Same
problem!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
F762b223a87f868db769f9a297fe976c?d=identicon&s=25 Mike W. (mike_w)
on 2013-10-09 12:37
After many more hours of wasted time, trawling the internet for help,
reading documentation I have finally given up on pybombs. I used the
build_gnurado script instead and all worked.

My advice to anyone who is not a guru is to not use pybombs at this
stage as it isn't quite working. I suspect a dependencies problem but as
nobody appears to be interested, I won't follow up.
194c350bcb8f4c2b6b0fabfeeb06a18a?d=identicon&s=25 Elijah B. (elijah_b)
on 2014-04-28 00:22
Just wanted to post the solution I came up with for this. I installed
with pybombs on a Ubuntu 12.04 laptop and had the same problem.  As has
been mentioned, OSS is no longer supported on Debian and its derivatives
by default, so you have to use ALSA. The pybombs recipe for gnuradio is
missing a dependency for the alsa dev package: libasound2-dev. Gnuradio
still builds successfully, but does not include support for alsa so on a
debian machine you're kind of sunk.  The fix is to install this package
manually with apt, and then rebuild gnuradio.  Do a pybombs clean
gnuradio, and then re-run the gnuradio install recipe.  You could
probably just run make from inside the gnuradio src directory too and
avoid rebuilding the whole thing.  The pybombs gnuradio recipe needs to
include libasound2-dev as a dependency.
This topic is locked and can not be replied to.