Forum: Ruby on Rails How do I change the jQuery version of a page?

99713a5ec23b5195250c9910eb13f01f?d=identicon&s=25 Jason Hsu, Android developer (Guest)
on 2013-08-13 18:15
(Received via mailing list)
I have two Rails sites (Bargain Stock Funds and Doppler Value Investing)
that use the Ransack gem.

In the Bargain Stock Funds search page (
http://www.bargainstockfunds.com/funds), the "remove" and "add
conditions"
buttons do not work in the production environment but do work in the
development environment.  For the life of me, I can't figure out why the
remove button works in the local environment but not in the production
environment.

I'm using a similar setup on my Doppler Value Investing search page (
http://www.dopplervalueinvesting.com/stocks), but the "remove" and "add
conditions" buttons work in both the local environment and the
production
environment.

Bargain Stock Funds has jQuery version 1.9.1 in the production
environment
but version 1.7.2 in the development environment.  Doppler Value
Investing
also has version 1.7.2.  Thus, I've come to the conclusion that I need
to
change the production environment of Bargain Stock Funds to jQuery
1.7.2.

My questions:
1.  How did my production environment end up with jQuery 1.9.1 instead
of
jQuery 1.7.2?
2.  How do I switch my production environment from jQuery 1.9.1 to
jQuery
1.7.2?

The source code for my Bargain Stock Funds site is at
https://github.com/jhsu802701/bsf .

The source code for my Doppler Value Investing web site is at
https://github.com/jhsu802701/dvi .
99713a5ec23b5195250c9910eb13f01f?d=identicon&s=25 Jason Hsu, Android developer (Guest)
on 2013-08-13 19:10
(Received via mailing list)
It turned out that jQuery version 1.9.1 was being mandated by files in
the
public/assets directory in Bargain Stock Funds. The Doppler Value
Investing
file had no public/assets directory. So I removed the public/assets
directory from Bargain Stock Funds, and the buttons work as expected.
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.