Forum: Ruby-core [ruby-trunk - Bug #8754][Open] Stop checking for old REXML versions

233c279c012ebac792aaa805f966cbc7?d=identicon&s=25 steveklabnik (Steve Klabnik) (Guest)
on 2013-08-08 16:49
(Received via mailing list)
Issue #8754 has been reported by steveklabnik (Steve Klabnik).

----------------------------------------
Bug #8754: Stop checking for old REXML versions
https://bugs.ruby-lang.org/issues/8754

Author: steveklabnik (Steve Klabnik)
Status: Open
Priority: Normal
Assignee:
Category: lib
Target version:
ruby -v: 2.1.0-dev
Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN


Given that Ruby 2.0 ships with REXML 3.1.7.3, and both REXML and RSS are
in the standard library, there should be no way to have an REXML < 2.5.
054b5f6b8afdd5f6190bad08e46cd782?d=identicon&s=25 zzak (Zachary Scott) (Guest)
on 2013-08-08 18:34
(Received via mailing list)
Issue #8754 has been updated by zzak (Zachary Scott).

Status changed from Open to Assigned
Assignee set to kou (Kouhei Sutou)


----------------------------------------
Bug #8754: Stop checking for old REXML versions
https://bugs.ruby-lang.org/issues/8754#change-40997

Author: steveklabnik (Steve Klabnik)
Status: Assigned
Priority: Normal
Assignee: kou (Kouhei Sutou)
Category: lib
Target version:
ruby -v: 2.1.0-dev
Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN


Given that Ruby 2.0 ships with REXML 3.1.7.3, and both REXML and RSS are
in the standard library, there should be no way to have an REXML < 2.5.
Ee6ffca720cc428d70247dcd7377dd48?d=identicon&s=25 kou (Kouhei Sutou) (Guest)
on 2013-08-09 16:54
(Received via mailing list)
Issue #8754 has been updated by kou (Kouhei Sutou).


Thanks! I've merged it.
The code was written before lib/rss/ is bundled in Ruby.
----------------------------------------
Bug #8754: Stop checking for old REXML versions
https://bugs.ruby-lang.org/issues/8754#change-41047

Author: steveklabnik (Steve Klabnik)
Status: Closed
Priority: Normal
Assignee: kou (Kouhei Sutou)
Category: lib
Target version:
ruby -v: 2.1.0-dev
Backport: 1.9.3: UNKNOWN, 2.0.0: UNKNOWN


Given that Ruby 2.0 ships with REXML 3.1.7.3, and both REXML and RSS are
in the standard library, there should be no way to have an REXML < 2.5.
This topic is locked and can not be replied to.