Forum: GNU Radio Build problems on mac os 10.8

11814a24d50e08d3a242151451afaf1b?d=identicon&s=25 Ching (Guest)
on 2013-08-02 18:58
(Received via mailing list)
Hi,

I try to build gnuradio on mac os 10.8 using macports. But failed to
build
"py27-wxpython-devel".

Here is the detail the log:

cports.org/release/tarballs/ports/x11/xorg-libpthread-stubs
:debug:main OS darwin/12.4.0 (Mac OS X 10.8) arch i386
  N   RO main.log                       unix │ utf-8 │ no ft   22%  LN
415
C 54

:info:build Exit code: 1
:error:build org.macports.build for port py27-wxpython-devel returned:
command execution failed
:debug:build Error code: CHILDSTATUS 30849 1
:debug:build Backtrace: command execution failed
    while executing
"system -nice 0 $fullcmdstring"
    ("eval" body line 1)
    invoked from within
"eval system $notty $nice \$fullcmdstring"
    invoked from within
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: targets not executed for py27-wxpython-devel:
org.macports.activate org.macports.build org.macports.destroot
org.macports.install
:notice:build Please see the log file for port py27-wxpython-devel for
details:

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py27-wxpython-devel/py27-wxpython-devel/main.log


Anyone know how to resolve this build problem? Thanks.

Best regards,
Cheng Chi
C539637020fd56193dd6daec746c4a84?d=identicon&s=25 Tom Rondeau (Guest)
on 2013-08-03 18:17
(Received via mailing list)
On Fri, Aug 2, 2013 at 12:57 PM, Ching <chengchibt@gmail.com> wrote:
> 54
> "eval system $notty $nice \$fullcmdstring"
>
>
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py27-wxpython-devel/py27-wxpython-devel/main.log
>
>
> Anyone know how to resolve this build problem? Thanks.
>
> Best regards,
> Cheng Chi


Unfortunately, our OSX guru Michael Dickens is on vacation right now,
and I'm not able to help with OSX issues too much. I know Dickens has
posted a lot of his work on this mailing list for how to use Mac ports
to install GNU Radio. Have you been following his instructions?

--
Tom
Visit us at GRCon13 Oct. 1 - 4
http://www.trondeau.com/grcon13
Bc7e5a4798b9bb4e311a26b41dce2fbc?d=identicon&s=25 Ian Buckley (Guest)
on 2013-08-03 22:28
(Received via mailing list)
First step, follow the instructions in the error message, in my
experience there's lots of useful information in the log file:
781e96b7bd64e8833d71e3914cb1594a?d=identicon&s=25 Michael Dickens (Guest)
on 2013-08-05 20:39
(Received via mailing list)
On Aug 3, 2013, at 9:16 AM, Tom Rondeau <tom@trondeau.com> wrote:
> Please see the log file for port py27-wxpython-devel for details:
>
>
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_python_py27-wxpython-devel/py27-wxpython-devel/main.log

Hi Ching - I'm back from a wonderful vacation, completely off the grid
for 1 week.

I know there has been a lot of work recently to get the WX ports better
aligned with their purposes, so possibly the port in issue
(py27-wxpython-devel) is no longer the way to go for GNU Radio's WXGUI.
I haven't had time yet to see what's going on with the WX ports; I've
just read about them in commit logs.

Here's what I recommend doing if this is still an issue

{{{
sudo port clean py27-wxpython-devel
sudo port selfupdate
sudo port install py27-wxpython-devel
}}}

and if that fails, then:

{{{
cp `port logfile py27-wxpython-devel`
~/Desktop/log-py27-wxpython-devel.txt
bzip2 ~/Desktop/log-py27-wxpython-devel.txt
}}}

and then email me, off-list, the resulting compressed logfile.  I'll
look it over and get back to you and we'll work out a way to get GNU
Radio working for you, eventually.

If the above works, then try "sudo port install gnuradio +full" again to
see what comes of it.

Feel free to email me off-list with any issues trying to install the
gnuradio port within MacPorts, even if the issue is not with GNU Radio
itself.  I'll help folks out as my time allows, which in the past few
months has meant 1-2 emails per day of advice per issue. - MLD
781e96b7bd64e8833d71e3914cb1594a?d=identicon&s=25 Michael Dickens (Guest)
on 2013-08-06 03:58
(Received via mailing list)
There's a ticket open at <https://trac.macports.org/ticket/39781 > with
this issue, so it's being tracked and worked on.  I do not yet have a
good solution except to revert back to the prior version if you still
have it installed.  WX has been a pain for a long time, and likely will
remain so for a while longer.  I'll post again once I know more or
figure out a work-around. - MLD
781e96b7bd64e8833d71e3914cb1594a?d=identicon&s=25 Michael Dickens (Guest)
on 2013-08-15 20:42
(Received via mailing list)
wxWidgets and wxPython are still hosed in MacPorts.  I've tried to
convince the maintainer of those to revert wxWidgets back to @2.9.4,
since that worked with all of the dependent ports; but, he has refused
to do so while he (and others, including me) work on a branch to fix
this massive problem (wx within MacPorts).  In the meantime, you can
still install GNU Radio without wxgui, by specifying each variant you
wish -- just not +wxgui.  So, instead of using +full, you could use:
{{{
sudo port install gnuradio
+docs+grc+jack+orc+portaudio+python27+qtgui+sdl+swig+uhd+wavelet
}}}
and get everything except wxgui.  I tried "sudo port install gnuradio
+full -wxgui" but that fails for some reason; I'll ask on the MacPorts
list to see what they say.  I will let the list know when some
resolution has come of this issue, but I think this is the best
work-around for now (and, yes, it works for me). - MLD
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.