Forum: Ruby What version gems of qtruby4 or qtbindings for x86 mingw32 gem can run on ruby1.8.7/win7

919075ac27ec28a3647784db21aed08f?d=identicon&s=25 wels xiong (welsxiong)
on 2013-07-22 02:50
I hava tried all version of qtbindings for x86 mingw32 from v4.6.3.0 to
v4.8.3.0 on MS windows 7, but found no one can run on ruby1.8.7, all of
them are occured the followed error:

C:/Ruby187/lib/ruby/gems/1.8/gems/qtbindings-4.6.3.0-x86-mingw32/lib/1.8/qtruby4.so:
127:  .... (LoadError)

It seems qtbindings are not compatible to ruby1.8.7 but ruby1.9.3, so
what verion of qtbindings can run on ruby1.8.7.

Also I have tried qtruby4-2.1.0-mswin32.gem on ruby1.8.7/win7, when I
execute the sample spinboxdelegate, some error are occured:

C:\Ruby187\bin\ruby.exe -e
$stdout.sync=true;$stderr.sync=true;load($0=ARGV.shift)
C:/Ruby187/lib/ruby/gems/1.8/gems/qtruby4-2.1.0-x86-mswin32/examples/itemviews/spinboxdelegate/main.rb
./spinboxdelegate.rb:56:in `method_missing': undefined method `setData'
for #<Qt::StandardItemModel:0x447f9f0 objectName=""> (NoMethodError)
  from ./spinboxdelegate.rb:56:in `setModelData'
  from
C:/Ruby187/lib/ruby/gems/1.8/gems/qtruby4-2.1.0-x86-mswin32/lib/Qt/qtruby4.rb:469:in
`method_missing'
  from
C:/Ruby187/lib/ruby/gems/1.8/gems/qtruby4-2.1.0-x86-mswin32/lib/Qt/qtruby4.rb:469:in
`exec'
  from
C:/Ruby187/lib/ruby/gems/1.8/gems/qtruby4-2.1.0-x86-mswin32/examples/itemviews/spinboxdelegate/main.rb:51
  from -e:1:in `load'
  from -e:1

Process finished with exit code 1

I don't know qtruby4-2.1.0 support what version of Qt? Is that
underlying Qt has no such setData method in the QAbstractItemModel  or
QStandardItemModel, or qtruby4-2.1.0 hasn't implemented fully of the Qt?

Does someone have these problem, and what should i do to fix that
problem?
15000f55138ae94b0f362ed7c625461a?d=identicon&s=25 unknown (Guest)
on 2013-07-22 16:42
(Received via mailing list)
Am 22.07.2013 02:50, schrieb wels xiong:
> I hava tried all version of qtbindings for x86 mingw32 from v4.6.3.0 to
> v4.8.3.0 on MS windows 7, but found no one can run on ruby1.8.7

Sorry I cannot help with your actual question, but I just would like
to note: unless you have a very good reason to use 1.8.7, you probably
shouldn't. It's not maintained by the Ruby core team anymore, see

   http://www.ruby-lang.org/en/news/2013/06/30/we-retire-1-8-7/


Regards,
Marcus
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.