Forum: Ruby on Rails Installing RVM Problems

F0bff799afc4b2d963c2e9614ee90d5c?d=identicon&s=25 Jayant S. (jayant_s)
on 2013-07-19 08:11
How do I update my zsh if I am getting the error message, ” WARNING: In
case of using Zsh, version 4.3.12 / 5.0.0+ is recommended, you have
4.3.11, errors to be expected.” when installing RVM? I am new to
developing with Ruby and the Ruby community and am starting with Michael
Hartl's Rails Tutorial.
Ce5e201eca55d4f79d0ead9acc91d544?d=identicon&s=25 Dheeraj Kumar (Guest)
on 2013-07-19 08:30
(Received via mailing list)
upgrade_oh_my_zsh
Aa082c8b00a50928e5860dcd70bf2368?d=identicon&s=25 tamouse m. (tamouse_m)
on 2013-07-19 09:36
(Received via mailing list)
On Jul 18, 2013, at 11:11 PM, Jayant S. <lists@ruby-forum.com> wrote:

> How do I update my zsh if I am getting the error message,  WARNING: In
> case of using Zsh, version 4.3.12 / 5.0.0+ is recommended, you have
> 4.3.11, errors to be expected. when installing RVM? I am new to
> developing with Ruby and the Ruby community and am starting with Michael
> Hartl's Rails Tutorial.
>

Not a ruby or rvm or rails issue. Sounds like an system admin issue. I
don't even know anyone that uses zsh, so can't recommend any sources of
info, short of the usual apt-get update && apt-get install
F0bff799afc4b2d963c2e9614ee90d5c?d=identicon&s=25 Jayant S. (jayant_s)
on 2013-07-19 09:47
apt-get are only for linux machines, and I am currently operating on a
Mac OSX. And for oh_my_zsh one needs a zsh of 4.3.9, but mine is
currently at 4.3.11. All I need is 4.3.12-5.0.0+ zsh in order to run RVM
without errors, or at least thats what the prompt intimates.
Af2ce6689213fdb78913a9662b18da6b?d=identicon&s=25 Rick Lloyd (ricklloyd)
on 2013-07-19 12:43
(Received via mailing list)
On Friday, July 19, 2013 3:47:49 AM UTC-4, Ruby-Forum.com User wrote:
>
> apt-get are only for linux machines, and I am currently operating on a
> Mac OSX. And for oh_my_zsh one needs a zsh of 4.3.9, but mine is
> currently at 4.3.11. All I need is 4.3.12-5.0.0+ zsh in order to run RVM
> without errors, or at least thats what the prompt intimates.
>
> --
> Posted via http://www.ruby-forum.com/.
>

zsh is available in source form from http://www.zsh.org.  You need to
follow the instructions there to download from a site appropriate for
your
location.  It comes as a (b or g)zipped archive so you pull in the file,
unpack it, and follow the instructions in the *INSTALL* file.  The
current
version is 5.0.2.
Af2ce6689213fdb78913a9662b18da6b?d=identicon&s=25 Rick Lloyd (ricklloyd)
on 2013-07-19 12:48
(Received via mailing list)
On Friday, July 19, 2013 6:42:44 AM UTC-4, Rick wrote:
>> --
>> Posted via http://www.ruby-forum.com/.
>>
> You can also install a binary from either MacPorts, Fink, or Homebrew.
3ec52ed58eb92026d86e62c39bdb7589?d=identicon&s=25 Michal Papis (mpapis)
on 2013-07-19 13:52
(Received via mailing list)
This messages is intended only for Zsh users -> "In case of using Zsh" -
so
if you do not use Zsh you can ignore it

I have also changed the message to explain it better:
https://github.com/wayneeseguin/rvm/compare/c26ce1...
F0bff799afc4b2d963c2e9614ee90d5c?d=identicon&s=25 Jayant S. (jayant_s)
on 2013-07-19 18:03
I do not explicitly use zsh, but I also do not know if at any point, my
terminal will need to do so. I googled the error message and another
github link came up from you, Michal Papis:
https://github.com/wayneeseguin/rvm/issues/2029, where you commented
that there is no way to tell if a user is using zsh. I tried to fix the
problem following the instructions in that forum, with your link to the
code under ea789c1, but the code was too long for me to copy/paste and I
don't know how to use GitHub that well to get code from the website
directly to my terminal.

I feel like I should just stop worrying about this and move on with the
tutorial, but will I experience errors as my original message states?
Aa082c8b00a50928e5860dcd70bf2368?d=identicon&s=25 tamouse m. (tamouse_m)
on 2013-07-19 23:40
(Received via mailing list)
On Jul 19, 2013, at 12:47 AM, Jayant S. <lists@ruby-forum.com> wrote:

> apt-get are only for linux machines, and I am currently operating on a
> Mac OSX. And for oh_my_zsh one needs a zsh of 4.3.9, but mine is
> currently at 4.3.11. All I need is 4.3.12-5.0.0+ zsh in order to run RVM
> without errors, or at least thats what the prompt intimates.

homebrew will do the same sort of thing on a mac.
Aa082c8b00a50928e5860dcd70bf2368?d=identicon&s=25 tamouse m. (tamouse_m)
on 2013-07-19 23:43
(Received via mailing list)
On Jul 19, 2013, at 9:03 AM, Jayant S. <lists@ruby-forum.com> wrote:

> I feel like I should just stop worrying about this and move on with the
> tutorial, but will I experience errors as my original message states?
>

If you don't know what shell you are using, you should find out. There
are a few ways to do this, of course. But the simplest in my mind is
open Terminal, and type echo $SHELL at the command line. Unless it is
zsh, ignore the warning and move on. If you decide at some point in the
future that you do want to use zsh, hopefully you'll also be
knowledgeable enough by that point to know why you do, and what sorts of
things you might need to change.

My suspicion here is that you saw the warning from rvm, panicked, and
thought you needed to do something. If you're just using the defaults
the Mac comes with, you can safely ignore it.
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.