Forum: Ruby on Rails problem with git push heroku

174dad5d84e4dce9b21365418d5765ae?d=identicon&s=25 Annapoorna R (Guest)
on 2013-07-01 07:58
(Received via mailing list)
using rails 3.2.13 ruby 1.9.3,

git push heroku
Everything up to date

heroku open
Application Error

An error occurred in the application and your page could not be served.
Please try again in a few moments.

If you are the application owner, check your logs for details.
heroku logs

2013-07-01T05:42:06.385740+00:00 app[web.1]:    from
/app/vendor/bundle/ruby/2.0.0/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:251:in
`require'

2013-07-01T05:42:06.385364+00:00 app[web.1]:    from
/app/vendor/bundle/ruby/2.0

.0/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:251:in
`block in require'

2013-07-01T05:42:06.385364+00:00 app[web.1]:    from
/app/vendor/bundle/ruby/2.0

.0/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:236:in
`load_dep

endency'

2013-07-01T05:42:06.385364+00:00 app[web.1]:    from
/app/vendor/bundle/ruby/2.0

.0/gems/activesupport-3.2.13/lib/active_support/dependencies.rb:251:in
`require'

 2013-07-01T05:42:06.385740+00:00 app[web.1]:    from
/app/vendor/bundle/ruby/2.0

.0/gems/rack-1.4.5/lib/rack/builder.rb:51:in `instance_eval'

2013-07-01T05:42:06.385740+00:00 app[web.1]:    from /app/config.ru:3:in
`block

in <main>'

2013-07-01T05:42:06.385740+00:00 app[web.1]:    from
/app/vendor/bundle/ruby/2.0

.0/gems/rack-1.4.5/lib/rack/server.rb:200:in `app'

2013-07-01T05:42:06.385740+00:00 app[web.1]:    from
/app/vendor/bundle/ruby/2.0

.0/gems/rack-1.4.5/lib/rack/builder.rb:40:in `eval'

2013-07-01T05:42:06.385740+00:00 app[web.1]:    from /app/config.ru:in
`<main>'

2013-07-01T05:42:06.385740+00:00 app[web.1]:    from
/app/vendor/bundle/ruby/2.0

.0/gems/rack-1.4.5/lib/rack/builder.rb:51:in `initialize'

2013-07-01T05:42:06.385879+00:00 app[web.1]:    from
/app/vendor/bundle/ruby/2.0

.0/gems/railties-3.2.13/lib/rails/commands.rb:50:in `tap'

2013-07-01T05:42:06.385740+00:00 app[web.1]:    from /app/config.ru:in
`new'

2013-07-01T05:42:06.385879+00:00 app[web.1]:    from
/app/vendor/bundle/ruby/2.0

.0/gems/railties-3.2.13/lib/rails/commands/server.rb:70:in `start'

2013-07-01T05:42:06.385740+00:00 app[web.1]:    from
/app/vendor/bundle/ruby/2.0

.0/gems/rack-1.4.5/lib/rack/builder.rb:40:in `parse_file'

2013-07-01T05:42:06.385879+00:00 app[web.1]:    from
/app/vendor/bundle/ruby/2.0

.0/gems/rack-1.4.5/lib/rack/server.rb:304:in `wrapped_app'

2013-07-01T05:42:06.385740+00:00 app[web.1]:    from
/app/vendor/bundle/ruby/2.0

.0/gems/railties-3.2.13/lib/rails/commands/server.rb:46:in `app'

2013-07-01T05:42:06.385879+00:00 app[web.1]:    from
/app/vendor/bundle/ruby/2.0

.0/gems/railties-3.2.13/lib/rails/commands.rb:50:in `<top (required)>'

2013-07-01T05:42:06.385879+00:00 app[web.1]:    from
/app/vendor/bundle/ruby/2.0

.0/gems/railties-3.2.13/lib/rails/commands.rb:55:in `block in <top
(required)>'

2013-07-01T05:42:06.385879+00:00 app[web.1]:    from
/app/vendor/bundle/ruby/2.0

.0/gems/rack-1.4.5/lib/rack/server.rb:254:in `start'

2013-07-01T05:42:06.385879+00:00 app[web.1]:    from script/rails:6:in
`<main>'

2013-07-01T05:42:06.385879+00:00 app[web.1]:    from script/rails:6:in
`require'



2013-07-01T05:42:07.492202+00:00 heroku[web.1]: Process exited with
status 1

2013-07-01T05:42:07.507152+00:00 heroku[web.1]: State changed from
starting
to c

rashed

2013-07-01T05:42:19.074727+00:00 heroku[web.1]: State changed from
crashed
to st

arting

2013-07-01T05:42:22.547997+00:00 heroku[web.1]: Starting process with
command `b

undle exec rails server -p 16404`

2013-07-01T05:42:24.720522+00:00 app[web.1]: DEPRECATION WARNING: You
have
Rails

 2.3-style plugins in vendor/plugins! Support for these plugins will be
removed

in Rails 4.0. Move them out and bundle them in your Gemfile, or fold
them
in to

your app as lib/myplugin/* and config/initializers/myplugin.rb. See the
release

notes for more on this:
http://weblog.rubyonrails.org/2012/1/4/rails-3-2-0-rc2-h

as-been-released. (called from <top (required)> at
/app/config/environment.rb:5)



2013-07-01T05:42:24.720522+00:00 app[web.1]: DEPRECATION WARNING: You
have
Rails

 2.3-style plugins in vendor/plugins! Support for these plugins will be
removed

in Rails 4.0. Move them out and bundle them in your Gemfile, or fold
them
in to

your app as lib/myplugin/* and config/initializers/myplugin.rb. See the
release

notes for more on this:
http://weblog.rubyonrails.org/2012/1/4/rails-3-2-0-rc2-h

as-been-released. (called from <top (required)> at
/app/config/environment.rb:5)


set gemfile to gem 'pg'
E6c21b324e3728b81766d880aa066aa1?d=identicon&s=25 Saikiran Mothe (saikiranmothe)
on 2013-07-01 08:04
(Received via mailing list)
Hi,

https://devcenter.heroku.com/articles/rails3#deplo...


Just follow the steps mentioned there.'

Thanks,
Sai
174dad5d84e4dce9b21365418d5765ae?d=identicon&s=25 Annapoorna R (Guest)
on 2013-07-01 08:07
(Received via mailing list)
m done with that this is for the second deployment with updated code...
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.