Forum: GNU Radio build-gnuradio (02-06-2013) does build gnuradio but with errors

30b5db0e0af5e6d5ed363381e9cbb25d?d=identicon&s=25 Ben Z (Guest)
on 2013-06-03 20:23
(Received via mailing list)
Hi.

Decided to refresh my system, started clean with Ubuntu 12.04 LTS 64
bits
on an I3 system.

Had to re-install Gnuradio and noticed that the build-gnuradio script
failed install. Then I noticed the remarks from Marcus that only the
newest
version would install but I was running a one week old version. So I did
get the newest build-gnuradio script and started it.

It does install Gnuradio, but at the start of the installation some
Dutch
language complaints appear. I translated these to English so that means
the
text is not 100% right but the library names are.

Building dependency tree
The status information is read ... ready
E: Could not find package libgruel *
E: Could not find any package by regex 'libgruel *'
Reading package lists ... ready
Building dependency tree
The status information is read ... ready
E: Could not find package libgruel0 *
E: Could not find any package by regex 'libgruel0 *'
Reading package lists ... ready
Building dependency tree
The status information is read ... ready
E: Could not find package libgnuradio *
E: Could not find any package by regex 'libgnuradio *'
Reading package lists ... ready
Building dependency tree
The status information is read ... ready
E: Could not find package python-gnuradio *
E: Could not find any package by regex 'python-gnuradio *'

Gnuradio does run, but when I load the multimode receiver there are
errors
like
>>> Error: Block key "osmosdr_source_c" not found in Platform - grc(GNU
Radio Companion) with the connection could not be made errors.

So I did grab the latest gr-osmosdr and did cmake ../ in the build
folder.
Then the errors as pasted below appeared:

pe2bz@pe2bz:~/gr-osmosdr/build$ cmake ../
-- Build type not specified: defaulting to release.
-- Extracting version information from git describe...
-- Configuring Boost C++ Libraries...
CMake Warning at CMakeLists.txt:147 (find_package):
  Could not find a configuration file for package "Gnuradio" that is
  compatible with requested version "3.7.0".

  The following configuration files were considered but not accepted:

    /usr/local/lib/cmake/gnuradio/GnuradioConfig.cmake, version: 3.6.5.0



-- checking for module 'gnuradio-iqbalance'
--   package 'gnuradio-iqbalance' not found
-- Could NOT find GNURADIO_IQBALANCE (missing:
GNURADIO_IQBALANCE_LIBRARIES GNURADIO_IQBALANCE_INCLUDE_DIRS)
-- gnuradio-uhd not found.
-- Could NOT find GNURADIO_UHD (missing:  GNURADIO_UHD_INCLUDE_DIRS)
-- gnuradio-fcd not found.
-- Could NOT find GNURADIO_FCD (missing:  GNURADIO_FCD_INCLUDE_DIRS)
-- checking for module 'libosmosdr'
--   package 'libosmosdr' not found
-- libosmosdr not found.
-- checking for module 'libmirisdr'
--   package 'libmirisdr' not found
-- libmirisdr not found.
-- checking for module 'libhackrf'
--   package 'libhackrf' not found
-- Could NOT find LIBHACKRF (missing:  LIBHACKRF_LIBRARIES
LIBHACKRF_INCLUDE_DIRS)
CMake Error at CMakeLists.txt:159 (message):
  GnuRadio Runtime required to build gr-osmosdr

-- Configuring incomplete, errors occurred!

At this moment I am lost what to (try to) fix first and last. Is the
absence of osmosdr the result of the error messages build-gnuradio gave
me ?

Thanks in advance for your replies,

Ben
558c40b97bd1af8d912424757714bda9?d=identicon&s=25 Marcus Leech (Guest)
on 2013-06-03 20:31
(Received via mailing list)
_______________________________________________
Discuss-gnuradio mailing list
Discuss-gnuradio@gnu.org
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.