Forum: Italian Ruby user group Dipendenze non necessarie?

E8207f1f5e8546a57de6f7a2babf6513?d=identicon&s=25 Maurizio Totti (Guest)
on 2013-05-22 11:06
(Received via mailing list)
Ciao a tutti,
scusate la domanda sa SuperNiubbo, ma proprio non capisco una cosa.
Sto tentando di ricreare una "vecchia" collezione gemset per far
rifunzionare un'applicazione rails 2.x (addirittura inizialmente
2.0.2)

Tra le varie gemme da installare c' ancestry della quale per non ho
modo di sapere la versione usata originariamente. Sono andato quindi
sul sito di rubygems.org per capire la versione pi adatta a "quel
periodo". Ho visto che per utilizzando la versione 1.3.0 avrei
soddisfatto l'unica dipendenza ossia "activerecord >= 2.3.14" (io ho
dovuto installare la 2.3.18).
Ho provato ad installare la gemma specificando la versione ed anche
con l'opzione "--conservative" sperando che non venissero installate
alte gemme.
Ebbe mi vengono installate sempre anche:
 activesupport-3.2.13
 builder-3.0.4
 activemodel-3.2.13
 arel-3.0.2
 tzinfo-0.3.37

Non capisco perch...
Mi potreste indicare che cantonata ho preso?
Grazie mille in anticipo.

--
Maurizio Totti
B731002ef4fa2ee7423e4b15e177f5b3?d=identicon&s=25 Stefano Verna (Guest)
on 2013-05-22 11:16
(Received via mailing list)
Ciao, se dai un occhio al Gemfile.lock dovresti riuscire a capire quali
gemme richiedono activerecord 3.2.x come dipendenza!

--
Stefano Verna
Cell: (+39) 349-1769335

weLaika - Applicativi Ruby on Rails, Siti Wordpress
http://dev.welaika.com <http://welaika.com> • info@welaika.com •
011-23.86.330
P. IVA e C.F. 10300060018


2013/5/22 Maurizio Totti <maurizio.totti@gmail.com>
E8207f1f5e8546a57de6f7a2babf6513?d=identicon&s=25 Maurizio Totti (Guest)
on 2013-05-23 09:24
(Received via mailing list)
Grazie mille per la risposta Stefano.
Il responsabile  paperclip-2.7.0, solo che a questo punto non capisco
perch su https://rubygems.org/gems/paperclip/versions/2.7.0 venga
indicato come necessario activerecord >= 2.3.0 :-(

Tra le altre cose proprio leggendo in
./gems/paperclip-2.7.0/Gemfile.lock trovo

PATH
  remote: .
  specs:
    paperclip (2.7.0)
      activerecord (>= 2.3.0)
      activesupport (>= 2.3.2)
      cocaine (>= 0.0.2)
      mime-types

GEM
  remote: http://rubygems.org/
  specs:
    activemodel (3.2.1)
      activesupport (= 3.2.1)
      builder (~> 3.0.0)
    activerecord (3.2.1)
      activemodel (= 3.2.1)
      activesupport (= 3.2.1)
      arel (~> 3.0.0)
      tzinfo (~> 0.3.29)
... etc etc

Qando scritto in PATH/specs  quello che trovo anche sul rubygems.org
mentre sembra essere applicato quello che c' in GEM/specs

Non ho capito molto, come funziona il meccanismo delle dipendenze?
Grazie mille

Il 22 maggio 2013 11:16, Stefano Verna <stefano.verna@welaika.com> ha
scritto:
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.