Forum: JRuby Rake Can't Require Logging Gem?

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
486ca04f06d968004643ce5b47376ded?d=identicon&s=25 Keith B. (keith_b)
on 2013-05-10 18:43
(Received via mailing list)
All -

I'm trying to use the "logging" gem for the first time, and have a

If I have this file, x_spec.rb:

require 'rspec'
require 'logging'

...then I get this output when I run rspec x_spec.rb:

> rspec x_spec.rb
LoadError: no such file to load -- logging
          require at org/jruby/
           (root) at

Interestingly, if I load with ruby instead of rspec,it works (which also
proves that the gem is installed):

> ruby x_spec.rb

If I run rspec in MRI 1.9, it works:

> rspec x_spec.rb
No examples found.

Finished in 0.00006 seconds
0 examples, 0 failures

What's going on?  Am I missing something simple?

Thanks for any help,
486ca04f06d968004643ce5b47376ded?d=identicon&s=25 Keith B. (keith_b)
on 2013-05-10 20:19
(Received via mailing list)
Now this appears not to work for MRI 1.9 as well. ;(

- Keith
This topic is locked and can not be replied to.