Forum: Inkscape Problem with drawing - bkacp square on export

79732b7d3021152a70d3b4b4d6ad032f?d=identicon&s=25 Johan Vromans (Guest)
on 2013-05-08 17:40
(Received via mailing list)
Hi,

I'm using Inkscape 0.48.4 on Fedora 17.

I have a drawing that I save in SVG format that I want to embed in an
OpenOffice (LibreOffice) text document.

When imported in OpenOffice, I get a black rectangle covering part of
the drawing. It does not matter whether I save in Inkscape SVG or plain
SVG.

When I use display (from ImageMagick) to show the SVGs, I also get the
black rectangle. In FireFox, both SVGs show fine.

When I save in OpenOffice Draw (ODG) format I loose all texts in the
image.

Help is appreciated.

You can find the drawing and sample dislay in
http://www.squirrel.nl/pub/xfer/uploads/3C1j41IOGG...

Thanks.

-- Johan
340db464063049cf1c1527b5ed80a24d?d=identicon&s=25 darkweasel (Guest)
on 2013-05-08 18:09
(Received via mailing list)
Am 2013-05-08 17:39, schrieb Johan Vromans:
> When I use display (from ImageMagick) to show the SVGs, I also get the
> black rectangle. In FireFox, both SVGs show fine.

The SVG in the zip file you posted has at least one flowRoot element.
Flowed text is an Inkscape extension that isn't in the SVG standard, so
it can cause unexpected results in other programs.

Solution: select all flowed text objects you have in Inkscape and do
Text -> Convert to plain text (or similar, I'm using a non-English
localization). If it still doesn't work then, it's most likely a bug in
the other software (LibreOffice/OpenOffice/ImageMagick).
Aefd46e73e6b7449c5ce1ce0156797d2?d=identicon&s=25 ~suv (Guest)
on 2013-05-08 18:27
(Received via mailing list)
On 2013-05-08 17:39 +0100, Johan Vromans wrote:
>
> When I use display (from ImageMagick) to show the SVGs, I also get the
> black rectangle. In FireFox, both SVGs show fine.
>
> When I save in OpenOffice Draw (ODG) format I loose all texts in the
> image.
>
> Help is appreciated.
>
> You can find the drawing and sample dislay in
> http://www.squirrel.nl/pub/xfer/uploads/3C1j41IOGG...

1) Flowed text
There are two empty 'Flowed text' elements in your drawing (with no text
content). The frame of such 'Flowed text' objects may be rendered as
black rects (unset fill) in some SVG renderers (flowed text is not part
of the current SVG 1.1 specification).

Since the flowed text objects contain no actual text, they do not render
visibly in Inkscape, and thus cannot be easiyl spotted, selected and
deleted.

This aspect of the issue with flowed text is tracked in
- Bug #485269 “Invisible and unselectable flow region in image”
  <https://bugs.launchpad.net/inkscape/+bug/485269>

To avoid creating such invisible text frames, be careful when using the
text tool to not create frames (for flowed text) inadvertently by
click+dragging on the canvas (to create regular text, click once, and
enter the text right away).


For general issues with flowed text, please read:
- Inkscape FAQ: What about flowed text?
  <http://wiki.inkscape.org/wiki/index.php/FAQ#What_a...
and the section in the manual about flowed text:
-
<http://tavmjong.free.fr/INKSCAPE/MANUAL/html/Text-...


Attached is an 'Inkscape SVG' version of 'opstelling.svg' which has
those invisible flowed-text objects deleted. It should import in
LibreOffice without unexpected black rectangles, and render correctly in
ImageMagick's 'display' (uses librsvg).


2) Missing text in exported ODG
The problem with missing text when saving as ODG in Inkscape and opening
the exported file in LibreOffice is tracked for Inkscape here (fixed for
next major release 0.49):

- Bug #168268 “Exporting to OpenOffice format (odg) fails with text”
  <https://bugs.launchpad.net/inkscape/+bug/168268>


hth, ~suv
Aefd46e73e6b7449c5ce1ce0156797d2?d=identicon&s=25 ~suv (Guest)
on 2013-05-08 18:35
(Received via mailing list)
On 2013-05-08 18:26 +0100, ~suv wrote:
> On 2013-05-08 17:39 +0100, Johan Vromans wrote:

>> When I save in OpenOffice Draw (ODG) format I loose all texts in the
>> image.

>> You can find the drawing and sample dislay in
>> http://www.squirrel.nl/pub/xfer/uploads/3C1j41IOGG...

> 2) Missing text in exported ODG
> The problem with missing text when saving as ODG in Inkscape and opening
> the exported file in LibreOffice is tracked for Inkscape here (fixed for
> next major release 0.49):
>
> - Bug #168268 “Exporting to OpenOffice format (odg) fails with text”
>   <https://bugs.launchpad.net/inkscape/+bug/168268>

Attached is an ODG version exported with current (unstable) Inkscape
trunk (r12323), which renders the text visibly outlined in LibreOffice
4.0.1 on OS X 10.7.5.
79732b7d3021152a70d3b4b4d6ad032f?d=identicon&s=25 Johan Vromans (Guest)
on 2013-05-08 23:11
(Received via mailing list)
Wow, this is what I call support :)

Thank you all for the replies. The problem is clear and --most
important-- solved now!

-- Johan
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.