Forum: Ruby-Gnome 2 install error

5a8016fb9b529f86fcfe27ec87a7de7b?d=identicon&s=25 Neel P. (neel_p)
on 2013-04-18 18:43
I tied installing this on Ruby but got error and then VR does not come
up.

C:\Ruby200>gem install visualruby
Fetching: require_all-1.2.1.gem (100%)
Successfully installed require_all-1.2.1
Fetching: pkg-config-1.1.4.gem (100%)
Successfully installed pkg-config-1.1.4
Fetching: glib2-1.2.6-x86-mingw32.gem (100%)
Successfully installed glib2-1.2.6-x86-mingw32
Fetching: atk-1.2.6-x86-mingw32.gem (100%)
Successfully installed atk-1.2.6-x86-mingw32
Fetching: cairo-1.12.4-x86-mingw32.gem (100%)
Successfully installed cairo-1.12.4-x86-mingw32
Fetching: pango-1.2.6-x86-mingw32.gem (100%)
Successfully installed pango-1.2.6-x86-mingw32
Fetching: gdk_pixbuf2-1.2.6-x86-mingw32.gem (100%)
Successfully installed gdk_pixbuf2-1.2.6-x86-mingw32
Fetching: gtk2-1.2.6-x86-mingw32.gem (100%)
Successfully installed gtk2-1.2.6-x86-mingw32
Fetching: vrlib-0.0.33.gem (100%)
Successfully installed vrlib-0.0.33
Fetching: gtksourceview2-1.2.6-x86-mingw32.gem (100%)
This library is experimental.
Successfully installed gtksourceview2-1.2.6-x86-mingw32
Fetching: visualruby-0.1.2.gem (100%)
Successfully installed visualruby-0.1.2
Parsing documentation for require_all-1.2.1
Installing ri documentation for require_all-1.2.1
Parsing documentation for pkg-config-1.1.4
Installing ri documentation for pkg-config-1.1.4
Parsing documentation for glib2-1.2.6-x86-mingw32
unable to convert "\x90" from ASCII-8BIT to UTF-8 for lib/1.9/glib2.so,
skipping

unable to convert "\x90" from ASCII-8BIT to UTF-8 for lib/2.0/glib2.so,
skipping

Installing ri documentation for glib2-1.2.6-x86-mingw32
Parsing documentation for atk-1.2.6-x86-mingw32
unable to convert "\x90" from ASCII-8BIT to UTF-8 for lib/1.9/atk.so,
skipping
unable to convert "\x90" from ASCII-8BIT to UTF-8 for lib/2.0/atk.so,
skipping
Installing ri documentation for atk-1.2.6-x86-mingw32
Parsing documentation for cairo-1.12.4-x86-mingw32
unable to convert "\x90" from ASCII-8BIT to UTF-8 for lib/1.9/cairo.so,
skipping

unable to convert "\x90" from ASCII-8BIT to UTF-8 for lib/2.0/cairo.so,
skipping

Installing ri documentation for cairo-1.12.4-x86-mingw32
Parsing documentation for pango-1.2.6-x86-mingw32
unable to convert "\x90" from ASCII-8BIT to UTF-8 for lib/1.9/pango.so,
skipping

unable to convert "\x90" from ASCII-8BIT to UTF-8 for lib/2.0/pango.so,
skipping

Installing ri documentation for pango-1.2.6-x86-mingw32
Parsing documentation for gdk_pixbuf2-1.2.6-x86-mingw32
unable to convert "\x90" from ASCII-8BIT to UTF-8 for
lib/1.9/gdk_pixbuf2.so, sk
ipping
unable to convert "\x90" from ASCII-8BIT to UTF-8 for
lib/2.0/gdk_pixbuf2.so, sk
ipping
Installing ri documentation for gdk_pixbuf2-1.2.6-x86-mingw32
Parsing documentation for gtk2-1.2.6-x86-mingw32
unable to convert "\x90" from ASCII-8BIT to UTF-8 for lib/1.9/gtk2.so,
skipping
unable to convert "\x90" from ASCII-8BIT to UTF-8 for lib/2.0/gtk2.so,
skipping
Installing ri documentation for gtk2-1.2.6-x86-mingw32
Parsing documentation for vrlib-0.0.33
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/add.png, skippi
ng
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/brick.png, skip
ping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/brick_link.png,
 skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/bug.png, skippi
ng
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/bullet_black.pn
g, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/bullet_toggle_m
inus.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/bullet_toggle_p
lus.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/date.png, skipp
ing
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/delete.png, ski
pping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/find.png, skipp
ing
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/macFFBgHack.png
, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/package.png, sk
ipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/page_green.png,
 skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/page_white_text
.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/page_white_widt
h.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/plugin.png, ski
pping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/ruby.png, skipp
ing
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/tag_blue.png, s
kipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/tag_green.png,
skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/transparent.png
, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/wrench.png, ski
pping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/wrench_orange.p
ng, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
doc/images/zoom.png, skipp
ing
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
img/image-x-generic.png, s
kipping
Installing ri documentation for vrlib-0.0.33
Parsing documentation for gtksourceview2-1.2.6-x86-mingw32
unable to convert "\x90" from ASCII-8BIT to UTF-8 for
lib/1.9/gtksourceview2.so,
 skipping
unable to convert "\x90" from ASCII-8BIT to UTF-8 for
lib/2.0/gtksourceview2.so,
 skipping
Installing ri documentation for gtksourceview2-1.2.6-x86-mingw32
Parsing documentation for visualruby-0.1.2
unable to convert "\x89" from ASCII-8BIT to UTF-8 for img/close.png,
skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for img/folder.png,
skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for img/glade.png,
skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for img/gtk-edit.png,
skipping

unable to convert "\x89" from ASCII-8BIT to UTF-8 for img/obj.png,
skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for img/png.png,
skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for img/rb.png,
skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for img/ruby.png,
skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for img/splash.png,
skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for img/unknown.png,
skipping
unable to convert "\xE2" from ASCII-8BIT to UTF-8 for
visualruby_examples/active
_record/db/development.sqlite3, skipping
unable to convert "\xE2" from ASCII-8BIT to UTF-8 for
visualruby_examples/active
_record2/db/development.sqlite3, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
visualruby_examples/all_wi
dgets/bin/splash.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
visualruby_examples/drag_d
rop/img/folder.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
visualruby_examples/drag_d
rop/img/glade.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
visualruby_examples/drag_d
rop/img/gtk-edit.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
visualruby_examples/drag_d
rop/img/obj.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
visualruby_examples/drag_d
rop/img/png.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
visualruby_examples/drag_d
rop/img/rb.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
visualruby_examples/drag_d
rop/img/ruby.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
visualruby_examples/drag_d
rop/img/unknown.png, skipping
unable to convert "\x89" from ASCII-8BIT to UTF-8 for
visualruby_examples/listvi
ew/bin/audio-x-generic.png, skipping
Installing ri documentation for visualruby-0.1.2
Done installing documentation for require_all, pkg-config, glib2, atk,
cairo, pa
ngo, gdk_pixbuf2, gtk2, vrlib, gtksourceview2, visualruby (7 sec).
11 gems installed

C:\Ruby200>vr
C:/Ruby200/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in
`require': c
annot load such file -- rubygems/builder (LoadError)
        from
C:/Ruby200/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in
 `require'
        from
C:/Ruby200/lib/ruby/gems/2.0.0/gems/visualruby-0.1.2/vr:15:in `<top
 (required)>'
        from C:/Ruby200/bin/vr:23:in `load'
        from C:/Ruby200/bin/vr:23:in `<main>'
5a8016fb9b529f86fcfe27ec87a7de7b?d=identicon&s=25 Neel P. (neel_p)
on 2013-04-19 20:41
any help would be good to debug this, thanks
Neel
3396e4a3df8a840faec520af8555a400?d=identicon&s=25 Mario Steele (Guest)
on 2013-04-19 21:07
(Received via mailing list)
This is due to a change in RubyGems' setup of the API.
rubygems/builder.rb
has been merged into rubygems/package.rb, and the API has changed as
well.
 This comes from Ruby 2.0 / RubyGems 2.0.  The best thing I can suggest,
is
to try out the new version of the IDE I'm working on, which is currently
only available from Bitbucket Git repository.
http://bitbucket.org/visualruby/ide

I will be pushing some updates to the IDE to restore the Gem management,
as
well as building gems, hopefully soon.

hth,

Mario


On Fri, Apr 19, 2013 at 2:41 PM, Neel P.
<ruby-forum-incoming@andreas-s.net>wrote:

> apps and a phenomenal toolset for data science. Developers can use
> our toolset for easy data analysis & visualization. Get a free account!
> http://www2.precog.com/precogplatform/slashdotnewsletter
> _______________________________________________
> ruby-gnome2-devel-en mailing list
> ruby-gnome2-devel-en@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/ruby-...
>



--
Mario Steele
Fleet Captain
CO - Geo 99
CO - USS T'hy'la
XO - Diplomatic Corps - Second Life
http://www.iftcommand.com/chapters/thyla/
http://www.trekfederation.com
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.