Forum: Ruby Gem dependency tool

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
B078cb4f4fb473c7a54d1fc36d10c70e?d=identicon&s=25 Regis d'Aubarede (raubarede)
on 2013-03-21 17:50
Here a little script for detection gem & version used for some
requirements :
https://gist.github.com/raubarede/5214546

example :

>ruby dependency.rb gtk3
require gtk3
pkg-config           1.1.4   => test-unit:>= 0 / test-unit-notify:>= 0 /
glib2                1.2.3   => pkg-config:>= 0 / test-unit:>= 2
gio2                 1.2.3   => glib2:>= 1.2.3
atk                  1.2.3   => glib2:>= 1.2.3
cairo                1.12.4  => pkg-config:>= 0 / bundler:>= 0 /
test-unit-notify:>= 0 / rake-compiler:>= 0 / packnga:>= 0
pango                1.2.3   => cairo:>= 1.10.0 / glib2:>= 1.2.3
gdk_pixbuf2          1.2.3   => glib2:>= 1.2.3
gdk3                 1.2.3   => atk:>= 1.2.3 / pango:>= 1.2.3 /
gdk_pixbuf2:>= 1.2.3
gtk3                 1.2.3   => glib2:>= 1.2.3 / gio2:>= 1.2.3 / atk:>=
1.2.3 / pango:>= 1.2.3 / gdk_pixbuf2:>= 1.2.3 / gdk3:>= 1.2.3
This topic is locked and can not be replied to.