Forum: GNU Radio Osmocom supporting Rafael R820T SDR?

34ca4305e0456e8510a1d4d7009a12d0?d=identicon&s=25 Tommy Tracy II (Guest)
on 2013-03-18 16:58
(Received via mailing list)
Attachment: signature.asc (494 Bytes)
_______________________________________________
Discuss-gnuradio mailing list
Discuss-gnuradio@gnu.org
https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
558c40b97bd1af8d912424757714bda9?d=identicon&s=25 unknown (Guest)
on 2013-03-18 17:05
(Received via mailing list)
On 18 Mar 2013 11:56, Tommy Tracy II wrote:

> Dear List,
>
> I
just received the NooElec R820T SDR USB dongle with antenna to test some
of my GNU Radio code. This particular dongle uses the R820T SDR. Does
anyone know if osmocom supports it, or if it works at all?
>
> I see
that osmocom supports
>
http://sdr.osmocom.org/trac/wiki/rtl-sdr#SupportedHardware [1]
>
> The
code below shows that the rtl_test program detected the tuner, but
failed because it =! E4000. Is that the only tuner currently supported,
or is there a command-line flag I can use to toggle tuners?
>
>
----------
> tjt7a@bt:~/sdr$ sudo rtl_test -t
> Found 1 device(s):
>
0: ezcap USB 2.0 DVB-T/DAB/FM dongle
>
> Using device 0: ezcap USB 2.0
DVB-T/DAB/FM dongle
> Found Rafael Micro R820T tuner
> Supported gain
values (29): 0.0 0.9 1.4 2.7 3.7 7.7 8.7 12.5 14.4 15.7 16.6 19.7 20.7
22.9 25.4 28.0 29.7 32.8 33.8 36.4 37.2 38.6 40.2 42.1 43.4 43.9 44.5
48.0 49.6
> No E4000 tuner found, aborting.
> ----------
>
> Tommy
James Tracy II
> Ph.D Student
> High Performance Low Power Lab
>
University of Virginia
> Phone: 913-775-2241

Most of the "stuff" in
rtl_test is intended to test specific features of the E4000, but the
librtlsdr drivers and gr-osmosdr *do* definitely support the R820T --
for a few months now.



Links:
68e4cb2871861bbe64d2eb3d42ca298e?d=identicon&s=25 Alexandru Csete (Guest)
on 2013-03-18 17:22
(Received via mailing list)
On Mon, Mar 18, 2013 at 4:56 PM, Tommy Tracy II <tjt7a@virginia.edu>
wrote:
> The code below shows that the rtl_test program detected the tuner, but
> failed because it =! E4000. Is that the only tuner currently supported, or
> is there a command-line flag I can use to toggle tuners?

Try rtl_test without any options.
The -t option is for benchmarking the E4000 tuner.

Alex
34ca4305e0456e8510a1d4d7009a12d0?d=identicon&s=25 Tommy Tracy II (Guest)
on 2013-03-18 17:47
(Received via mailing list)
Excellent! Thank you. It seems to work.

Tommy James Tracy II
Ph.D Student
High Performance Low Power Lab
University of Virginia
Phone: 913-775-2241
This topic is locked and can not be replied to.