Forum: GNU Radio Problem with Transmitting bits

7d3b4ec7a2599f26ade394b86f5f4e41?d=identicon&s=25 manjusha (Guest)
on 2013-03-15 20:16
(Received via mailing list)
Hello Everyone,

Tranmit_bits.png
<http://gnuradio.4.n7.nabble.com/file/n40170/Tranmi...

I am trying to send bits from my Transmitter to Receiver.Attached is the
transmitter.As you can see there are two file sinks.So,here are the
questions i have..

1.When i write 1 bit to my msg_tx file i  get to see no transmission
over
the USRP (I saw it with the help of other file sink). And it continues
to
show no transmission until i have 6 bits on the msg_tx file.It works
when i
have 7 and more bits.I thought may be it wants to transmit a Byte(8
bits) of
data.But,it transmits 7 bits also.Please explain why it is so..

2.The same with 9 bits of data on my msg_tx file,it transmits only 8
bits of
data and leaves other bits .It continues continues to do this until i
have
14 bits on my file..i.e for 14 bits,it transmits 8 bits only and leaves
the
other 6 bits ..works fine for 15 and 16 bits.

3.When i put my File source to 'NO REPEAT' the transmission is none for
any
number of bits.Do i have make any changes in the .grc file for this to
work?Please explain.

Thanks,
Manjusha
7d3b4ec7a2599f26ade394b86f5f4e41?d=identicon&s=25 manjusha (Guest)
on 2013-03-18 19:34
(Received via mailing list)
please answer if you know how to fix these issues
Please log in before posting. Registration is free and takes only a minute.
Existing account

NEW: Do you have a Google/GoogleMail, Yahoo or Facebook account? No registration required!
Log in with Google account | Log in with Yahoo account | Log in with Facebook account
No account? Register here.