Forum: Rails I18n [HELP] strange result in production mode on remote server cannot find why it happens [rails 3.2.12]

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Kad K. (Guest)
on 2013-02-12 15:27
(Received via mailing list)
I have a simple  localization which is not working correctly for one
language in 'production' mode ... ( fine in dev, and fine in env
on localhost  )

in the view  ( haml)
= I18n.t(:is_written_by, scope: 'posts', author:

in locales
    is_written_by: "%{author} on "
    is_written_by: "%{author} le "

with  post.blogger_display_name => 'Isabelle'

In console : Dev mode  or Production mode , on localhost  : cool

> I18n.locale => :fr
> post = Post.first
> I18n.t(:is_written_by, scope: 'posts', author: post.blogger_display_name)
> => "isabelle le "
> I18n.locale = :en
> I18n.t(:is_written_by, scope: 'posts', author: post.blogger_display_name)
> => "isabelle on "

But after deployment, .. I got a ""translation missing:
fr.posts.is_written_by" when locale is :fr , and fine display when
is :en...
I deployed and redeployed again... no way , same error ..
I tried to debug with a remote console, in production mode ...  same
I am lost ... what should I do next to find where this issue is located

thanls for help
Kad K. (Guest)
on 2013-02-12 16:32
(Received via mailing list)
changed the scope => :posts  to :posting
Destroyed & re-created the yaml files then deployed again ...  running
should be a conflict w :posts key ...
no time for further enquiries ...

Le mardi 12 fvrier 2013 14:26:04 UTC+1, Erwin a crit :
This topic is locked and can not be replied to.