Forum: Ruby on Rails specified new ruby rvm now rails is broken

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Ec8b325dcad37dee7a0c358811353a80?d=identicon&s=25 wragen22 (Guest)
on 2012-11-01 05:40
(Received via mailing list)
Hi folks,
my terminal was loading up an older version of ruby so I installed the
latest with rvm and specified the rout in my .bash_profile.

Latest ruby is being used but getting this error when trying to run
rails

/Users/bradwrage/.rvm/gems/ruby-1.9.3-p286/gems/sqlite3-1.3.6/lib/sqlite3/sqlite3_native.bundle:
[BUG] Segmentation fault
ruby 1.8.7 (2012-02-08 patchlevel 358) [universal-darwin12.0]

Abort trap: 6


Any idea?
5f94b9b346c2aa648a80bc259978e5bc?d=identicon&s=25 Colin Law (Guest)
on 2012-11-01 10:21
(Received via mailing list)
On 1 November 2012 04:37, wragen22 <bradwrage@gmail.com> wrote:
> Hi folks,
> my terminal was loading up an older version of ruby so I installed the
> latest with rvm and specified the rout in my .bash_profile.
>
> Latest ruby is being used but getting this error when trying to run rails
>
>
/Users/bradwrage/.rvm/gems/ruby-1.9.3-p286/gems/sqlite3-1.3.6/lib/sqlite3/sqlite3_native.bundle:
> [BUG] Segmentation fault
> ruby 1.8.7 (2012-02-08 patchlevel 358) [universal-darwin12.0]

That looks as if you are running ruby 1.8.7.  What do you get if you
go into the top level folder of your rails project and do
ruby -v
rails -v

Colin
This topic is locked and can not be replied to.