Forum: IronRuby IronRuby igem not working

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Rahul D. (Guest)
on 2012-10-17 07:33
Hi All,

When trying to download the following gems from the cucumber wiki page,
I get the following error:

igem install cucumber —no-ri —no-rdoc
igem install iron-term-ansicolor —no-ri —no-rdoc

ERROR:  Could not find a valid gem 'slimgems' (>= 0) in any repository
ERROR:  While executing gem ... (Gem::RemoteFetcher::FetchError)
    Errno::ECONNREFUSED: No connection could be made because the target
actively refused it. - connect(2)

In addition I have tried other gems like rake, and get the same error as

I have no connection issues, being able to download gems from webpages
directly (no command line).

I repeated the same on normal ruby (MRI), and got the same error. A

Can anyone shed any light on how to resolve this? Much appreciated.

Many Thanks,
Rahul Dixit
Eduardo B. (Guest)
on 2012-10-17 20:56
Just as a reminder:

Are you running igem from a powershell or cmd screen that you opened as

I usually get that kind of confusing errors if I forget to "run as


This topic is locked and can not be replied to.